Yet another SQLite extension (Free)

extension

#42

@frdfsnlght, thanks for the info about extension.
@Karthikeyan_M, I’ll try to replicate the block you have and see what happen when i run it on emulator and device too. n the meantime, when possible, can you remove the opendatabase and closedatabase blocks out of the click event (put the open database after the importdatabase block in the screen1.initialize) and the closeatabase block in the screen1.backpress event (just close the db when you’re exiting your app) and see if you still get a frozen app?

Cheers
Lildinti


#43

@Lildinti, I changed the block as per your instruction. The app is not freezing and data is getting saved for that session. But after closing and reopening the app, saved data does not exist. I think by closing the app the insert transaction is not getting saved rather getting rolled back to its original state. Please find below the blocks for your perusal.


#44

blem is… you only need to import your database once.
If you have a look, you import the database (that is originaly blank) again! that why there’s no data!Try to make your Screen1.initiallize like this:
22

Should fix it and also ty adding the Transaction block and see if it works.
Cheers
Lldinti


#45

@Lildinti,You’ve made my day. Its working now. The data is getting saved and on re-opening the app contains the updated data.Thanks a lot.


#46

Glad to hear the good news and that we got it working.
Peace, brother.

Cheers
Lildinti


#47

Sir pls give some examples of how to import sqlite data in listpicker if possible pls give aia file


#48

Pls give aia file …


#49

#50

How to import database sqlite file in listpicker pls show example or aia file


#51


#52

sqlitesample.aia (70.3 KB)
I done like this only but unable to import in listpickerblocks


#53

if possible then please give aia file


#54

where is the database


and it is not a .sqlite file
Sketch%20(2)


#55

I upload in asset folder


#57

know i upload pls check


#58

sqlitesample new.aia (70.7 KB)


#59

sqlitesample new.aia (71.0 KB)
and you have to change the name of db in the blocks to book.sqlite


#60

What’s the problem now, when I have filled the data in it and I’m giving it a screen shot

sqlitesamplenew.aia (71.5 KB)


#61

try apptest.sqlite instead of apptest.sql


#62

sir if possible then pls give aia file as example