WiFimanager and /or TaifunWifi


#1

Hi,
I’m new on this forum but i ever know thunkable and a little appinventor.
I come to you for a problem that i have ever submit on another forum but i didn’t have the solution.
my phone is a honor 9 lite (emui/android 8.0)
i don’t find why wifimanager and taifunwifi don’t work in my app. the methode is call ->wifimanager1.wifilist and taifunwifi.availableSSIDs. Maybe are exactly the same methode but in the two case the method doesn’t work.
the question is ?
I’m alone with a honor or huwaei to have this problem? is it android 8.0? (i don’t think beacause Taifun has ever tested on a nexus5 (android 8.1) my phone find all network wifi but not the app.
i joined you a screen of my app. maybe there is an error.


thank you for your help!
Eric


#2

sorry for missing your answer…
you might want continue in your other thread https://community.thunkable.com/t/taifunwifi-bug-permission-update/28196/11?u=taifun
Taifun


#3

The same happened to me and I have the Galaxy Note 8 with Android version 8.0.0. It does not work.

In the cell phone of my wife Samsung Galaxy S8 with Android version 8.0.0, it works correctly.

It must be something specific in some cell phones.

I leave a thread that I did where I was sharing information.


#4

@Gabriel_Egea & @Eric_P
Does it work if you turn on Location(GPS)?


#5

hahahahaha I can not believe it! doing this, it works again on my Note 8.

Ken, you are a genius!

Thanks, now I can go back to work on my project.

PD:It works again in both the Taifun extension and the WIFImanager extension of AB


#6

thank you for finding the issue! :wink:
Taifun


#7

Unfortunately there is currently no way to turn it on automatically.(That I am aware of anyways)

For now use Activitystarter with Action set to “android.settings.LOCATION_SOURCE_SETTINGS”

This will allow the user to turn it on.


#8

I don’t believe it! …
it’s working! screen1 is ok!
even if there is not solution, i can to notify it to user.

my screen 2 bug (app crashed everytime after initialisation of screen2 : maybe the method accesspoint) may be i must activate torch for it! :stuck_out_tongue:
now i try to resolve the new bug!

a big thank to you all for your time!


#10

Try this one wifi2.apk (2.3 MB)
When app starts, it asks for permission.

/Boban


#11

Hi!
I have the same problem… I tried both activating GPS and the wifi2.apk and the problem is still there. I cannot see any SSID.
I am using a Xiaomi-MiA2. Any idea?

Thanks in advance!

Guille


#12

Hi,
I have a xiaomi redmi note 8, solved the problem giving the app permission to access the phone location,
Configuration > permissions > location and turn on the app