Why say Runtime Error?


i use the block for checking ad unit id.

also try with obfuscated Text
when i open this app then app say an error.
why say the error? how to fix it?


Are you using any extensions?


yes. I use Firebase Addon Extension FirebaseAddOn Extension (To be sponsored!)
app was working properly before use this extension. but i test a app with only Firebase Addon Extension then work properly. but when i import ti to my main project and add those block then got the error.


no one there for help me?


Apperently not. Be patient. Developers and supportteam are doing this in their freetime.


oh, sorry. But what is the problem on project?


The error message means something is not initialized correctly.
Try removing the extension and see if you still get the issue.


i used FirebaseAddOn Extension (To be sponsored!) extension. and completely fill up all block. when i test the extension on a test app then it working properly. when i add it my main project then it say the error. i tried to find the null point about 4 hour. :disappointed::disappointed:


Then you need to check the logic in your test-app and use it as template for your main-app


Can you tell me what are the reasons for this error?


I’m not the developer of that extension. The fact that it works in your test-app and not in another project, means you need to check your logic.

That’s all I know and can help


i was check it. but now i’m going to check again and inform you. what wrong or any thing.