Unable To Compile Apk And Copying Screen Error

bug
howto

#1

Hi there I’m creating a app for PDF and I have tried copy screen… But copied screen is not opening and Apk is not compiling…


Here I have copied c screen and target is d but d is not opening

Please Help … I think its bug because before copying screen all is ok… Please Help Me Its Very Important Project , Please Help…


#2

Here is what happens if I click on d screen (Copied Screen)


#3

And what does the bug report say?


#4


#5

Can you show your block with which you change screens?


#6

Yes ,


#7

Sorry thats unreadable. I can just see that you changed your packagename. Did you follow the guidelines for that?

https://help.appybuilder.com/tutorials/basic/package-name


#8

Sir there is no problem with package name… Because it works fine , the problem is with copied screen… After copying screen my app is not compiling and the screen name is d:(


#9

I have tested/compiled app before copying the screen and everything was
workings fine…


#10

I’m also unable to delete that screen


#11

Did you make backups of your project? What if you open an earlier version?


#12

Off-Topic: Why are you using an on-screen trackpad? AppyBuilder supports touch input.


#13

I’m comfortable with trackpad :slight_smile:.


#14

No… Bit Problem Is Solved Now… I Have Found A Way To Solve This Problem…
Export .aia file of the app and open it as archive and then delete the screen files(.bky & .scm) and upload the .AIA file again… :wink: please share this to anyone who is suffering from the similar problem :slight_smile:


#15

How many screens do you have by the way?


#16

7 screen… And in a week more than 13


#17

Its PDF app, so it has many screens for categories


#18

You will get in to trouble if you use to many screens? Why not rethink your app and work out if you can do it with less screens.

See tip 1.


#19

Thanks Dear , Its Helpful For Me :slight_smile: