Texting component


#1

Unfortunately, the texting component issue which has been resolved before is back with this release. I was able to build and update my app shortly before this release without any issue but after this release, I cannot build. Here is the error message:

Please help.


AppyBuilder Release - Now FREE and opensource!
#2

@contritrack Do you have a simple .aia to demonstrate the issue? Are you sure you don’t have any empty block-sockets?


#5

Yes. The .aia file I sent will demonstrate the issue. Just try to build without and with texting component.
Thanks.

Patrick


#6

Unfortunately the recent update has also not resolved the texting component issue. Currently, I cannot update my apps. I’m glad you acknowledged the issue. Any hope that this issue will be fixed soon? I’m eagerly waiting.
Thanks.


#7

@contritrack Did I acknowledge the issue? :slight_smile:
At any rate, I just loaded the .aia that you sent me and used the offline and it built properly.
Let me try the online version and I post-back how it goes


#8

Yes. but just drop texting component into the project. Even without codes, it won’t build.
That is the issue.
Patrick
.NB: if you can find the project in my account- Community Alert, Package name, com.contritrack.ca. The current version was uploaded successfully to the play store shortly before the last major release. But since then I cannot build. You may take a look at the project for better insight.
Thanks.

Patrick


#9

The isn’t Texting component. New projects with Texting components can generate .apk with no problem.
Running some more tests…


#10

I guessed the problem was solved naturally when it was first reported when other issues were fixed. I knew you were very busy, so when there was no response for a long time I left out texting feature to move on. After a long time, i tried it again and it worked. That was when I made the last update.
Texting component works without issues on some of my projects but I can’t figure out why this is happening with this project. Hope it resolves.
Thanks for your efforts.
Patrick.


#11

When was the last successful build with the texting component?


#12

Just before the free release. Specifically, I updated to Play Store on 27th October 2017. A day before the release.

Patrick


#13

I can feel you here. Building progressed to 100% but waiting indefinitely for barcode. With a little more efforts, we’ll be there.
Thanks.


#14

It works now!. I can now build with texting component in my project.
Thanks.


#15

That’s great. What changes did you make?


#16

I did not make any change. I kept trying at intervals. At a time,building progressed to 100% but waiting indefinitely for barcode. Then I knew you were working. Then came the announcement that the server will be down for 10 Mins. After the server came up again, I tried and built successfully. I think whatever issue you fixed before the build server came up again today fixed it.
Thank you.


#17

@Hossein The problem is back again. I have not been able to build the same project since yesterday. If I’m the only one experiencing this problem, I may have to revert back to the stable version without texting component. This information may however help to identify the cause if you made any changes to the server between Friday and Saturday.


#18

The problem seems to be having FireBaseDB and Texting component together. There seems to be some conflict of libraries. We are still checking into solution


Unable to Compile the apk
#19

Ok. I wish you success.
Thank you.