TableView Extension v3


#82

I am using data type String:

In my test app I have 2 columns, the first column is 13 characters and second column is 0-50 characters and I have over 5000 records and I’ve never had an issue.
Note: I am using a Samsung S8


#83

Gues it’s my sqlite that does trick, If I do it with the builtin sqlite this does not work.


But I’m using Taifun’s SQLite end then my method does work


#84

Hello,
Taifun’s sqlite returns a list of values (not enclosed in quotes) separated by a comma and the end-of-line is a newline character (\n).
If I give this list to the datasource of a tableview and do a build table, balues are shown.
But, when I retrieve numerical values (stored as integer) they are not shown, if I have text columns with numerical value in it, they are shown.
If I try to cast the integer to text nothing changes, if I put quotes around the numerical value it is shown.
How to circumvent this problem?

Another problem is with the column widths, sometimes they give the width of the maximum contents, sometimes they don’t, even the header columns is then split over sevceral lines.

I have a column which width is smaller than the column width, the first few rows are shown ok, the next rows have the value with a black rectangle under them, scrolling further in the table shows higher black rectangles.

If you want I can post or pm an example with this behaviour but it requires taifun’s extension wich is not for free.


#85

I haven’t tested this in any of the builders but try:
select cast(some_integer_column as text) from some_table

Currently, All cells in the row need to have the same amount of lines.


#86

It’s got something to do with shrinktofit property, if I put this to false, numeric columns are shown all column widths are ok, black boxes are gone


#87

In order to avoid horizontal scrolling I set the table arrangement to a HorizontalArrangement instead of a HorizontalScrollArrangement but this does not help , If my list contains to many columns the table is horizontal scrollable.

I can restrict the columns in my select but I need them because they will show up in a detail screen that will be shown when a row in the table is clicked. I want to pass the values from those columns to the detail screen.

I can choose to only pass the unique key of the table but then I have to re-retrieve the data from the sqlite database and that’s something I want to avoid.

Is this possible?


#88

Don’t use scroll Arrangement.

The scroll is automatic if the table is to wide for the screen it automatically enables Horizontal scroll.

If the table is to tall for the screen it automatically enables Vertical scroll.

You’d need to reduce the CellPadding and/or FontSize, remove some columns or reduce the amount of characters in the cell.

You could also set the screen to landscape orientation so more columns can fit on the screen.


#89

Hello,
I think I found another issue in latest version of tableviewe (the beta).
When you use one tableviewer for the headers and another one for the data you have to change fonts and colors in the top row of the data one, so far so good.
But the top row in a tableviewer is not selectable, I need to be able to click on a row to get the data ans start further processing, is there a way to change this behavior?


#90

Screenshot_20190218-082648_Chrome

Please review all options