Still Unable to Start WinStartBuildServer.cmd


Have you looked into this


When starting the server (backend or frontend), if window immediately closes, it could mean that:

  1. Your java path not setup properly - setup your java path or update script files to point to your java
  2. Address (8888) already in use (you may have to use task manager to kill java)



I already tried and nothing, ever without success


Sorry, I’m clueless

Either java path or that port 9990 is used by another program, show screenshot of yours listening ports

Check also task manager, kill all java task and start over by execute WinStartBuildServer and WinStartFrontend



Thanks all for your help. I have done all the things as mentioned. But still having the same problem. I am attaching screenshots as required by yourselves. I will also try to reply with logs if possible.


Thanks @dora_paz for your help. I have tried all the ways you suggested me but still no luck. I have attached some screenshots in my last post in reply of @Boban_Stojmenovic


Can you repost images of your environment variables
Folder where your java is

cmd of java path and javac

echo %JAVA_HOME%
javac -version



@Boban_Stojmenovic I am enclosing the required screenshots for your reference.



Hard to figure out what’s wrong

Make sure there is no space here

and here, also change to bin lower case letters, not what i think it helps but we should try to reflect the directory path

I also see that you have modified WinStartBuildServer, if so show us it too


and if everything looks good and it still doesn’t work then restart your computer



One thing I suspect, you are trying to run 64 bit java on 32 bit OS




Dear @Boban_Stojmenovic I have changed the Bin to Lowercase and also there’s no space in the java path. I am posting the WinStartBuildServer as well.

@echo off
echo “Starting AiLiveComplete BuildServer…”
cd BuildServer\lib
“%JAVA_HOME%\bin\java” -Xmx3g -cp layoutlib-api-24.3.0.jar;builder-1.3.0.jar;ecj-4.5.1.jar;common-24.3.0.jar;sdk-common-24.3.0.jar;activation-1.1.jar;jersey-bundle-1.3.jar;args4j-2.0.18.jar;jersey-multipart-1.3.jar;asm-3.1.jar;jettison-1.1.jar;BuildServer.jar;json.jar;CommonUtils.jar;jsr311-api-1.1.1.jar;CommonVersion.jar;localizer.jar;FastInfoset-1.2.2.jar;mail-1.4.jar;grizzly-servlet-webserver-1.9.18-i.jar;commons-io-2.0.1.jar;guava-14.0.1.jar;rome-0.9.jar;http-20070405.jar;bcprov-jdk15on-149.jar;bcpkix-jdk15on-149.jar;sdklib.jar;jackson-core-asl-1.9.4.jar;stax-api-1.0-2.jar;jaxb-api-2.1.jar;wadl2java.jar;jaxb-impl-2.1.10.jar;wadl-cmdline.jar;jaxb-xjc.jar;wadl-core.jar;jdom-1.0.jar -Dfile.encoding=UTF-8

I have downloaded 32bit java and I am running 32bit windows. Also I am able to take screenshot of buildserver cmd and enclosing it for reference.

Thanks for your help my dear.


Please tell me that if it is possible to build / test my apk via another way. or If anyone knows any alternate way as I am facing this problem since one week.


Since we discovered that your are running 32 bit and not 64 bit

Show me your folder path to java, it should look like this


And the path to your latest jdk, in my case
C:\Program Files (x86)\Java\jdk1.8.0_192

You have to change your environment variables to point to 32 bit version of java as you are still using
64 bit

I hope the changes get your server running because I’m also getting frustrated not being able to help you and not just you


Offline version - How to make it work in Windows 10

yesterday I tried to configure the environment variables as indicated @Boban_Stojmenovic but I was not successful either.
Today it occurred to me to take away the word bin and it works very well I am already compiling the apk


Hi, I have the same problem you had. I set everything according to the instructions, but when I click on the files WinStartFrontend and WinStartBuildServer, I get the cmd window and close again in a moment. And it doesn’t do anything. And it didn’t help me even to delete the bin. Please, give me an advice.


@Boban_Stojmenovic I am little bit confused. I have corrected the things as you mentioned earlier. Though, I am enclosing the screenshots and I hope that my problem will be solved in the Appybuilder Community.

Thanks and Best Regards!


I am running a 32bit OS


Honestly i don’t know why it doesn’t work on your system



Thanks @Boban_Stojmenovic you really tried hard my dear and I am trying hard as well. If it worked then I will reply with the solution so that it will help others.

Thanks & best regards!


Kindly go step by step with this video :

He is setup java for windows. in my experience not matter if it is 32 or 64 bit just refer to the right path in environment variable



Go to control panel - Programs - java - general - setting - restore default., security - restore security prompt then restart your PC