Runtime Error in some devices


#1

hello dear community members
I build an app with Appybuilder. It’s working smoothly on most of the devices.
But in few devices, it stops to run and show the runtime error. Can anybody suggest me something to solve this issue? it’s not on all devices just in few devices only.
RunTime Error Is
android.app.Notification$Builder.setColor


Notify Extension [Free]
#2

on which devices / Android version do you get that error?
what about providing a screenshot of that block you used?

Taifun


#3

.setColor was added in API21 Android OS v5.0 Lollipop so anything below Lollipop will display this error.

@Taifun is correct, it’s best to provide the OS versions of the devices that both have and don’t have the error and screenshots of relevant blocks.


#4

IT’s android 4.4.4 i think that’s why it’s getting errorUntitled


#5

Yes, this error would occur on KitKat because .setColor didn’t exist until Lollipop.


#6

Ken

Maybe you could add this check to your extension


#7

My Extension doesn’t use .setColor for this reason.


#8

it would help, if @LiveApp_Box could add a screenshot of the relevant blocks…
Taifun


#9

I agree(d) with you.


#10

Sorry for late to join the discussion. I use 2 notifier components 1 feature by Appybuilder and 1 notify extension by andres_cotes. I think this error because of the extension. I use to set a color in this extension. I’m posting the screenshot of blocks I use in it and the link of extension. I will change this and try again in the same lower OS version and let you know here what is the result.
I’m using this extension because of the feature in it. It notify my app users with a message when the time up even the app is closed or running in the background. IF there is any other way to notify user same as this, please suggest me. As i said I use this because it works even app closed by user.
Here is the screen shot.

the extension link Notify Extension [Free]


#11

Taifun has an extension that is similar to the one you are using but it doesn’t use .setColor.
You can get it here: http://puravidaapps.com/notification.php


#12

you can’t use that method for older devices
you might want to set the minimum API level to 21 manually
to modify the manifest, use AppToMarket https://groups.google.com/forum/#!forum/apptomarket
Taifun


#13

set color is not my priority. important is notification on time. Thank you for kind support. Appybuilder Community such great place to find solution for problems regarding code, bugs and etc.
Thank you all of you i appreciate your help.
I will check Taifun extension