Runtime Error, Error from Companion



Two days ago, working in my app, after adding just a notifier to debug an error, I started to get this error. Companion shows my app in a bad way, mixed components, no text… and I get a big error:

Error from Companion: java.lang.RuntimeException: invalid syntax in eval form:
<string>:3:1909: caught exception in inliner for #<procedure make> - java.lang.RuntimeException: no such class:

before this one, I got the same error regarding TaifunImage extension, but when I’ve deleted, I get the error related to another extension…
I’ve restarted companion, delete all disabled blocks, clean warnings… but I can’t find the error.



@Andres_Cotes’ CustomListView extension is causing this.


Hi Conor:

I don’t think that’s the problem. I’ve been testing the apps with that extension for weeks with no problem, and just before this error I was getting the same with Taifun Image extension. I mean, it seems that every extension I delete, I get the error with another one…


delete the folder /AppInventor on your device and try to reconnect again


Hi Taifun:

thanks for the answer. I’ve deleted the folder, but same error. After restart companinon, the folder is created, and the extensions and assets are copied.

I get the same error.

Thank you


While starting the companion app, all necessary assets and also the imported extensions of your project will be copied to your device. So in case the no such class error shows up, the extension code to run the extension is not available on your device. Without that code the companion app is not able to execute methods from the extension.

you might want to add your project into this thread so someone (probably @Hossein ?) can take a look what might be wrong…



Thanks again Taifun.

@Hossein, attached my project, maybe you can reproduce the error and get the solution?

Thanks in advance<a class="attachment"
SEMI_BQA.aia (151.9 KB)


@josejad your app uses two additional extensions. Not sure if theyare causing issue. Can you create a simple app that only includes rouse two extensions? Try it out with both AppyBuilder and MIT AI and let us know how it goes


Hi Hossein, I will try, the problem is I have been using this extensions in my app more than two months with no problems, and after adding a notify to debug, I start getting this error.