Project will not open (Maps and Location Sesnor)


#1

Hello community,

I have created a project 3 different times and toward the end of development, the project will not open after being saved. I have successfully tested the project throughout development and everything worked properly.

This is the error message I receive when I try to open the project:
foundIn = none
faultData = com.google.gwt.user.client.ui.AttachDetachException: Exception caught: Exception caught: Exception caught: Exception caught: Exception caught: Exception caught: Exception caught: (TypeError) : Cannot read property ‘lng’ of null
projectId = -1

For some background info: I am a high school teacher and I use AppyBuilder for my intro course. I was attempting to create an activity where students would build a “Digital Tour Guide” app and would gain experience with the Maps and Location Sensor components. I have not used these components much before and I am assuming they are the root of the issue.

Any help would be greatly appreciated, as I believe my students would enjoy the activity I have planned and creating the app.

Joe Mazzone


#2

Hello @JoeMazzone ,

Do you mean .project won’t open in AppyBuilder? Can you post exact name of your project?


#3

Thanks for the quick reply, @Hossein

In the list of “My Project” in my AppyBuilder account, I have multiple projects named variations of “DigitalTourGuide”.

Actually, I downloaded the .aia file after the first project gave me the issues. So here is an example of one of the app project files that will not open due to an error.
DigitalTourGuide_Solution2.aia (40.8 KB)


#4

@JoeMazzone

  1. Do you recall last updates before this issue happened?
  2. Is this happening when you are adding Circle?
  3. I tried your Map app in MIT AI and still receive same error about lng. Checking into it

#5

It could very well be the Circle component.

That was one of the last things added each instance of the project. I was using a slider to control the size of the circle so the user could customize a distance radius around their current location. I will try to create a similar project in MIT AI and see if I can replicate the issue. Then I will report to them if so.

I will update this forum once I check on this discovery. Please let me know if you discover any new information.

Joe


#6

@Hossein
I successfully built the project from scratch in MIT AI and in the end got the same results as with AB. The project worked great until I closed it out and tried to reopen it, I then received the error message and cannot open the project.

It seems this is not an AB specific issue, but an issue originating from MIT AI’s implementation of the component. I did report the issue to the MIT AI team.

Hossein, please let me know if you discover the issue/a fix.

Joe


#7

@JoeMazzone Please fill out an issue below and (if okay) upload your .aia into the issue-ticket:


#8

@Hossein
Being worked on. https://github.com/mit-cml/appinventor-sources/issues/1379


#9

my project was not open due to bugs http://gold.appybuilder.com/?locale=en#6430655988629504 please reach and solve the problem thank you.


#10

Can you give me the exact project name?
Also, how many screens / media files?