Problem with companion


Hey i noticed a problem with companion i tried to start my app to have a look how its looking, i done as usally i go on connect then live testing and then i scanned the code but then the qrcode disappeared and my app wont open at my phone he recognized the code but wont connect to him i pressed connect to code aswell and it is the newest version of the companion here are some screenshots of my app

have a nice day

btw im using the sidebar and actionbar extension from @Andres_Cotes
but i have set them to development aswell so it can be a problem with that
and i dondt get any error code


Create backup if your app using SaveAs. Then remove the extension and see if companion works properly


this all dont make any sense i deletet the extension then the companion worked then i recreated everthing like before now the companion works aswell and yesterday where i first build this app it worked aswell i havent done any changes but before it dosnt worked


Maybe it was taking time for your browser to communicate with the companion


i waited like 30 minn


Maybe you previously had other companions that were running in the background or maybe you had multiple browser sessions open our had to refresh browser to get new session?? Other than that, i don’t know what could be causing it


I recommend resetting your connection with the Companion App, then trying again when this happens. That’s always fixed it for me. Although, honestly, in final testing, I wind up building the app 5-10 times before I iron out all the bugs, as I don’t quite fully trust the Companion to render everything as it will look on final build.


One day I got this behaviour as well, the problem was that my phone switched to another wificonnection.
I noticed it when I saw that the IP adres as shown on the phone screen was an unusual one.