Problem importing my old appybuilder project to kodular


#1

I’m having trouble importing my project that works on the offline appybuilder to the new kodular.
When will the kodular be fully compatible with old projects created in the Appybuilder?

Sorry for my English! Thank you all!

Image attached:


#2

It will never be 100 percent compatible. That is impossible. Delete the component that is causing trouble and try again.


#3

OK. But is the Kodular platform really concerned with former AppyBuilder users?


#4

What do you mean by concerned. I removed your topic on the kodular forum because you already asked here.


#5

Concerned about the compatibility of the appbuilder components. I will have to start my existing project from scratch. Very sad!
Most of the components I used are not compatible


#6

Even so, I appreciate the support. :sob::cry::sweat:


#7

An easy way to see if your aia is fully compatible with Kodular is to use https://unchive.kodular.io/
Just upload your aia and all the incompatible components or extensions will be highlighted . For example in my aia DateUtils is incompatible with Kodular. After that you will easily know what to change in order to work with Kodular


#8

Thank you @dora_paz!
I will still have a lot of work! :sob:


#9

I wouldn’t put too much trust in this checker. It came up with no errors for my apps but still can’t import anything with the “spacer” component and every complex app (lots of blocks per page) has a load error and will not allow you to edit the blocks. I have had to go back to App Inventor and start again. Sooo much wasted time because they closed Appybuilder.


#10

That shouldn’t cause issue. When did you try?


#11

I just tried importing again (last time was March some time). It accepted the spacer components this time - nice job thanks. But still get errors on 3 screens. No idea why. The unchive page show no errors.

So when it imports it comes up with a number of errors like attached pic 1 and pic 2.
When you go into the individual screens, the faulty ones display error like pic 3.
An then when you go to the block editor, it’s totally corrupted with blocks missing and those that show are scrambled. See pics 4 and 5.

Any ideas?
Thanks … Andrew !!


#12

Do you have any collapsed blocks ? Maybe this will help you https://community.kodular.io/t/bug-when-collapsing-blocks/58805


#13

Thank you for your suggestion.
I read the link and checked for all block expanded and enabled.
Reimported, but same problem.
Also checked for third party extensions.
Cannot see any obvious pattern as it doesn’t affect all screens, only 3.

… Andrew !!


#14

Here is one of the screens that won’t import.
Can you see a reason why?

Thanks … Andrew !!


#15

It seems that you are using List view, remove those blocks in appybuilder that don’t exist in kodular, save and try again


#16

Although I am having trouble importing my project. I want to congratulate you all, Kodular is wonderful for Android app developers. I’m really enjoying Kodular! :heart_eyes::heart_eyes::star_struck::pray: @Peter @dora_paz @Andrew_Kerr @Hossein @Boban_Stojmenovic
I also loved the Kodular interface