Pirate Attack: Fight for Liberty


#1

This is a game, created by using the AppyBuider system.
You are very welcome to download and (almost more important) to rate the game, give suggestions and maybe point out bugs.
Although the game is fully released, additional levels will be added in the near future, so don’t be surprised if gameplay doesn’t last long.

Thanks for your help.
Mika

Google Play:
https://play.google.com/store/apps/details?id=com.appybuilder.MobileGamingLabs.PirateAttack_FightForLiberty


#2

Screenshots would be helpful.


#3

Those can be seen on the Google Play Store entry.


#4

I am unable to play it.
When I click on 1 in the screen below:

It switches to:

Before I get to play.


#5

I tried it, it is a very nice idea. The first time i collieded with island and was defeated instantly. :smiley:


#6

I tried to solve level 2 but there are now buttons shown to fire the cannon. Also I can´t throw anchor to stop the vessel.

Hm… :thinking:


#7

Hey,
thanks for your replies!
So first I reinstalled the game on Moto XPlay to see if the issue, noticed by @Ken, also appears in my case. It doesn’t. I have tested out every function so often before the release, I would have been surprised if it wouldn’t work properly now…
-> May you tell me the name of your device?

In addition I have checked the code and it doesn’t seem to be an coding error. Maybe i have reached the limits of Appy Builder, with all the ImageSprites and huge blocks of code…
I do not want to post any pics of my coding blocks here, moreover I really think that my skills in AB are at a very high level and that I would definitely find simple mistakes like that fastly - without wanting to be overbearing!

@Rene, you probably mean that no buttons to fire and stop the ship are displayed? Actually the game was tested on Moto XPlay, Moto Z and Nexus 7 and non of those issues appeared at all. So what should I do?

Thanks for your help and replies!
Mika


#8

I have a Samsung S8 running Android OS 8.0.0 Oreo


#9

What is the screen resolution of your devices? Mine is 2220x1080.


#10

I found the same problem as @Ken. I have a huawei p8 (pra-lx1) with android 8.0 screen resolution 1920x1080


#11

#13

It seems, the game knows your pirate skills in advance.

I have a Honor 6X with android 7.0 and resolution of 1080 x 1920. When i start the game, the first thing is that it tries to purchase something.


#14

I’ve seen that happen a couple of times as well.


#15

It seems, the game knows your pirate skills in advance.

Yeah, well… :slight_smile:

Thanks to @Ken for posting the video. I am working on an update to fix that issue.
Mika


#16

Different devices have different color saturation. Due to the fact that the whole level system is based on an two layered color-detection procedure, the answer to the problem is obvious:
The color that indicates that the ship is on water and not already on land, is shown to the system differently on my device and on yours. That’s just because of the varying color sauration. Simple problem but hard to find out.

Anyway I managed to fix that issue - now it’s your turn. Please update the game and see if it works for your phone.
With time I have to find out how much that colors vary. Hope it works for the future.
Mika

Edit:
In order not to burden the game with requests and requests again, the color indicator only is set once when the game is installed.
Everyone (2-5 current users/ including you) must reinstall the game to make the new indicator work!


#17

Unfortunately it’s still doing the same thing.

Also if I click on the bottom half of an icon, Play/Coins/etc. It doesn’t register the click.


#18

I updated the game and have the same issues now like Ken. Also there is too much advertising before the beginning of a battle. And after the advertising I get the screen “defeated”. And there are still no buttons to use.


#19

I deinstalled the app, installed it at 1:15 pm or 13:45 o´clock and have still no buttons.

I can drive along the sea but nothing else.

For your information: Honor 6X, 5" display at 1024 x 1920


#20

I am sorry for that!
And if I am seeing it right, the walls ar not on the positions on the map where they were supposed to be. I am working on the whole thing and all that I can do, is updating the game and see if any of the issues disappears. Thanks for your help!
Mika


#21

Ok Sir, don´t care about the buttons. As I reactivated the auto-rotate, they are on the expected position. I thought the auto-rotate wasn´t turned off again as I reinstalled your app.