Offline version - How to make it work in Windows 10

offline

#21

for how local but front end i upload, this work ok with companion


#22


#23

@Andres_Cotes Please check your server’s log for any warning messages


#24

Everything is working in offline version but the issue is… building apk failed…

Build failed! connect error: Connection refused: connect


#25

Probably you run only frontend server (WinStartFrontend.bat) start also Build server (WinStartBuildServer.cmd) . Without build server running you can not compile .apk


#26

If you have config the correct path, it may be because error: Could not reserve enough space for object heap.
Go to StartControl PanelSystemAdvanced system settingsadvanced(tab)Environment VariablesSystem VariablesNew :

Variable name: _JAVA_OPTIONS
Variable value: -Xmx512M

#27

I’ve done all this and still get the error: Build failed! connect error: Connection refused: connect


#28

Window 10 Java 8 JDK Latest installed
Path same as shown here
added ending
added Variable name: _JAVA_OPTIONS
Variable value: -Xmx512M
Restarted PC
Build failed! connect error: Connection refused: connect


#29

i tried all the above steps and its showing this to me :

Screenshot%20(198)

Help needed.


#30

First of all the command you should type is echo %JAVA_HOME% and not %JAVA-HOME% ( you use dash and not underdash). Check your variables for type mistakes like this one .


#31

Having same error using the offline version. More details from my post here earlier.

Here is my result when checking:
C:\Users\Mike>echo %JAVA_HOME%
C:\Program Files\Java\jdk1.8.0_221\jdk1.8.0_25

IS THIS CORRECT?


#32

Just these three settings and it’s working perfectly. :relaxed:


#33

Hmm

/Boban

I have to write unimportant text as it requires 20 characters to respond, Damn Damn Damn


#34

/Boban


#35

My latest Java update is showing under the path.
C:\Program Files\Java NOT C:\Program Files (x86)\Java

x86%20Path%20to%20Java%20Folder

Path%20to%20Java%20Folder

When doing the Java Updates they seem to go under C:\Program Files


#36

Use this then for your java path

C:\Program Files\Java\jdk1.8.0_221

/Boban


#37

SysVarB


#38

So use:

JAVA_HOME C:\Program Files\Java\jdk1.8.0_221

Yes?


#39

Yes

/Boban

I have to write unimportant text as it requires 20 characters to respond


#40

It’s working right here with these settings