Offline Builder issues


I’ve been blindsided by the online builder being taken down. I have an app that I need to build within the next few days - I can get the offline app builder working ok but the buildserver will not start - cmd window just flashes and disappears. I’ve set the JAVA HOME variable ok, nothing else running on port 8888.
Advice very welcome, but if anyone is willing to try and compile my app to an apk that would be awesome, would get me through the next few days. Thanks!


Build server uses port 9990 , frontend server uses 8888 port. Check if any of this port is in use by another app

Can't start buildserver

Thanks - good call but didn’t fix the problem. 9990 was being used by GEForce so I stopped that but no change, still flashes and disappears.


Have you tried to restart your computer after you stopped the app that was using the port 9990 ?


I’ll check this - thanks for your help, must go offline (NZ) but will try later - cheers


Sadly no improvement, have disabled ap using port 9990 and rebooted - Frontend starts ok but Buildserver just flashes and disappears immediately. Is there a log or debug or some way to find out why it fails? Cheers B


Did you check if Geforce is reusing the port after reboot



Yes, I did check, then I checked again afetr you asked and it s back! I have to run again but will keep trying, thanks for your patience.


I think Geforce loads a service in Windows - NVidia Network Services (NvNetworkService.exe). Open Services (Start Menu > Run and type services.msc) and see if such a service is running and if start up type is set to automatic . From there you can stop the service or change the start type, for example disable it or set it to start manual. Hope that helps.


Hi, yes I found the NVidia service and have disabled it, and rebooted the pc - nothing running on port 9990.
SAme result - window just flashes and disappears, although the first time I tried it almost seemed to hang around and generate about 1/2 screen of text. Can I redirect the output to a file?



Can you show us your JAVA_HOME

also show your Java folder




cheers Bruce



Make sure that Java 8 JDK is installed on your computer and path is setup properly. You’ll need JDK because jarsigner executable is required to create create a keystore certificate for your app

You are using jre version of java



Thank you! I installed the jdk version and changed the path and that solved my problem - I really appreciate your help and @dora_paz as well, fantastic!