My rewarded ad problem


#1

in one of my app rewarded ad have a problem .and i couldn’t find what is it yet.
i used Test Id and it was working
i used my real id with testmode true and it was working
but when i change testmode to false my ad fail to load always.i published and check it again.yup fail to load problem. do you have idea about this issue?

in my other app i used same blocks and its working.


#2

@edd did you set screen to responsive?


#3

yup i set screen responsive


#4

@edd have you seen the rewarded video tutorial by @PixiiBomb ?


#5

yup i watched . maybe i miss something. let me watch again


#6

i watched again. in this app i got failed to load error always. when i set testmode to false. if its true then its ok.


#7

Are you receiving an actual error message that says “failed to load”? Or is it just that nothing is happening when you click on the button?

This could be an internet issue, or it could be that your AdUnitID is brand new. The newly created AdUnitID could take up to 48 hours to register on AdMob.

You can try a couple of other things:
Load the ad when the screen starts, Show the Ad when you click on a button, Load another ad when the Ad closes.
Check out the Firebase tutorial I just uploaded for an example of these blocks. (Fast forward to 20:15)
(Points.Initialize, btn_plus.Click and RewardedVideo1.AdClosed)

Also make sure your Ad in Enabled in the Properties window.

If it still doesn’t work, there are 2 built in events in the Rewarded Video component called “AdFailedToLoad” and “AdFailedToShow”.

The Failed to Load event returns an errorCode and an errorMessage.
Try outputting the code and message to a label. The message should give you more information about why the ad wouldn’t load, but if that’s not helpful, try Googling the error code.


#8

yup . i used all blocks. i can not see rewarded ad from my device. but i ask someone download the APP and check working or not.says its working.can see rewarded video.
so i guess its about my device.
It seems solved :slight_smile: