Map.feature connection geojson


#1

When i tried to add a geojson file in source field using feature colletion, i encountered an error

Below is my geojson file. Original name map.geojson, i rename it to map.txt so i can upload it here
map.txt (1.8 KB)

Yes, my chrome is v63
image


Appybuilder server isn't working correctly why..?
#2

I took the file and tested in MIT AI and had same issue. To be honest, at this time, I don’t recall correct usage of this feature


#3

True. I tried to look for its example of use but cant find any.

I have tried using file field and string field on FeatureCollection and Polygon features but same result, either error or nothing happen on map,


#4

I did your test with the same results (internal error).

But I made a map.geojson from http://geojson.io and works fine.

I use chromium-browser 65.0.3325.181-0ubuntu0.14.04.1


#5

i was tried some time before
Copy the file from site whitch generate json geo and awalys give me error but not this error like yours


#6

The geoson interpreter seems to very picky about
carriage returns CR
and line feeds LF

You could try removing the LFs after the commas


#7

Same problem.

Simple test JSON

{“type”:“FeatureCollection”,“features”:[{“type”:“Feature”,“properties”:{“title”:“test”},“geometry”:{“type”:“Point”,“coordinates”:[33.10579562187195,33.94686432303015]}}]}

Cause exception:

notes = Browser: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36
foundIn = none
faultData = java.lang.NumberFormatException: For input string: "

How did you found whats wrong with JSON?

P.S>. It woudl be nice to see in AppyBuilder at least java stacktrace…


#8

can you send me a small example aia with only one or two markers with this? It makes me crazy, i tried a lot but could not take any result.