I've got an issue (same version a month ago that worked)


#1

Hi everyone,
since I upgraded to the 5.07 version of the companion I have the following problem, about the application:

  1. “Runtime error: invoke: no method named get value 'in class java.lang.bolean”
  2. cannot find the component: “test”

what happens?


#2

Are you just opening the companion or testing your application?


#3

testing my app…


#4

OK, thanks for being patient/with us today! Can you give me a list of components and extensions which you’re using in your application?


#5

i apologize I said an inaccuracy, I checked with a version 5.05 and the problem remains, it is a little less than a month that I do not work on my project, to my return when I generated an apk, the problems described above occurred , I have a lot of backup facts and they all have the same problem … and I’m 100% sure they worked


#6

Can I have a list of the components and extensions which you’re using in your application? Is one of them the Timer/Clock?


#7

unfortunately I use more than 100 components … on different screens


#8

What screen does the application show this error on? Give me a number from up to down on the screen dropdown. Which screen as an index, does this first?

Example

Screen1; Would be the first screen
Test; Would be the second screen
Then so on…


#9

the second screen, the problem occurs after performing the correct authentication with firebase and sends me to the second screen called “SEGNALAASSENZA” in my case, the screen does not let me see it


#10

as if it didn’t compile the same file as a month ago …


#11

Screen names are case sensitive. Can you show the blocks to call that screen please.


#12

Something similar happened to me and it was that I was working in a checkpoint, therefore, I had changed the name of the package without wanting to do it.

Check if you do not change the name of your project.


#13

a project that I have not changed, I have about 15/20 projects and all of them do the same problem, I didn’t change anything, a month ago they all worked !! a 2 year job …


#14

Have you followed Boban’s advice about Timer/Accelerometer/Screens?


#15

sorry, you are asking me to change my projects that have more than 100 clocks, when they worked all last month, this is not possible, before the last update everything worked, which is done every time you release an update is the user who has to work on his projects because the update has changed something?
I kindly ask the administrators to try any of my projects with the previous and current versions, you have my authorization to enter my projects … if you build an apk with the current version it doesn’t work, if you build an apk with the previous version all it works properly
that’s no good
@Hossein


#16

@Massimiliano_Fiorava Sorry for the issues you are facing. I’ll have a response for you by this Sunday. Thanks


It seems Clock Component Not working Properly
#17

thanks a lot Hossein


#18

This is not from companion.
Also from appybuilder. I don’t know what happened to appybuilder from last update or change same error to most of the people. Wait for appybuilder corrections.


#19

Maybe it’s because you have over 100 clocks


#20

I’ll look into previous changes and see if something might be causing it, @Ken do you know if this was possible after your PR or didn’t they push that yet?

EDIT #1

Do not respond Ken, your PR deals with the snackbar!

EDIT #2

Create a new project with one clock, tell us the result of testing. I honestly doubt it’s Appybuilders fault, and is because of how many clocks you have.

EDIT #3

Nothing from Release - March 15th has changed for clocks.

EDIT #4

It could be possible it’s because of the build server not being updated.