Installing AppyBuilder Personal (offline version) via Git


#21

Thats also what i did after git clone.


#22

In Windows 10 tutorial, I forgot to mention that Git for Windows is required in order to install and run Tortoisegit . You can download the latest version here, https://git-scm.com/downloads


#23

Added it to the tutorial. :+1:


#24

Thank you so much :smile:


#25

I can’t run startFrontend.sh.
I get following output:
AppyBuilderPersonal$ ./startFrontend.sh
SDK_BIN is: /home/pali/Irataim/Programozas/Android/AppyBuilder/OffLine_Szemelyes_verzio/AppyBuilderPersonal/AppEngine
Executing [/usr/lib/jvm/java-11-openjdk-amd64/bin/java, -D–enable_all_permissions=true, -Duse_jetty9_runtime=true, -Xbootclasspath/p:/home/pali/Irataim/Programozas/Android/AppyBuilder/OffLine_Szemelyes_verzio/AppyBuilderPersonal/AppEngine/lib/override/appengine-dev-jdk-overrides.jar, -classpath, /home/pali/Irataim/Programozas/Android/AppyBuilder/OffLine_Szemelyes_verzio/AppyBuilderPersonal/AppEngine/lib/appengine-tools-api.jar, com.google.appengine.tools.development.DevAppServerMain, --property=kickstart.user.dir=/home/pali/Irataim/Programozas/Android/AppyBuilder/OffLine_Szemelyes_verzio/AppyBuilderPersonal, --no_java_agent, --port=8888, --address=0.0.0.0, /home/pali/Irataim/Programozas/Android/AppyBuilder/OffLine_Szemelyes_verzio/AppyBuilderPersonal/GUIServer]
júl. 30, 2019 8:37:26 DE. com.google.appengine.tools.admin.OutputPump run
SEVERE: Unexpected failure while trying to record errors.
java.io.IOException: Stream closed
at java.base/java.io.BufferedInputStream.getBufIfOpen(BufferedInputStream.java:176)
at java.base/java.io.BufferedInputStream.read(BufferedInputStream.java:342)
at java.base/sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
at java.base/sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
at java.base/sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
at java.base/java.io.InputStreamReader.read(InputStreamReader.java:185)
at java.base/java.io.BufferedReader.fill(BufferedReader.java:161)
at java.base/java.io.BufferedReader.readLine(BufferedReader.java:326)
at java.base/java.io.BufferedReader.readLine(BufferedReader.java:392)
at com.google.appengine.tools.admin.OutputPump.run(OutputPump.java:36)
at java.base/java.lang.Thread.run(Thread.java:834)

júl. 30, 2019 8:37:26 DE. com.google.appengine.tools.admin.OutputPump run
SEVERE: Unexpected failure while trying to record errors.
java.io.IOException: Stream closed
at java.base/java.io.BufferedInputStream.getBufIfOpen(BufferedInputStream.java:176)
at java.base/java.io.BufferedInputStream.read(BufferedInputStream.java:342)
at java.base/sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
at java.base/sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
at java.base/sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
at java.base/java.io.InputStreamReader.read(InputStreamReader.java:185)
at java.base/java.io.BufferedReader.fill(BufferedReader.java:161)
at java.base/java.io.BufferedReader.readLine(BufferedReader.java:326)
at java.base/java.io.BufferedReader.readLine(BufferedReader.java:392)
at com.google.appengine.tools.admin.OutputPump.run(OutputPump.java:36)
at java.base/java.lang.Thread.run(Thread.java:834)

How to solve this problem?


#26

Java 8 JDK is needed to run the server . I believe you have java 11 and not 8 so check your version


#27

Indeed.
java -version
openjdk version “11.0.3” 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+7-post-Debian-5)
OpenJDK 64-Bit Server VM (build 11.0.3+7-post-Debian-5, mixed mode, sharing)


#28

Just install Java 8 JDK and you will be able to run both servers , frontend and build


#29

I already have installed JAVA 8 JDK beside JAVA 11 JDK.
I just switched to the JAVA 8 JDK by running command:
sudo update-alternatives --config java
Now startFrontend.sh can start successfully.
Thanks!


#30

yesterday i try offline version, added java 8, and everything worked good, build apk etc, but today morning when i try build apk i see this messagre “Build failed! connect error: Connection refused: connect” . help pls

!!! now everything OK

when i started system today, i runed only WINSTARTFRONTIED without WINSTARTBUILDSERVER , and this was main error, in did both of this files must be started. sorry for anxiety and thank you for colobaration. wrong word. for your help


#31

Probably you run only frontend server (WinStartFrontend.bat) start also Build server (WinStartBuildServer.cmd) . Without build server running you can not compile .apk


#32

yes, you absolutely right, i did namely this error. thank you


#33

I just tried out AppyBuilder Personal with the AppyBuilder application on my smartphone.
On my smartphone there is an Android version 9.
When I try to scan QRcode to get connected to my project in AppyBuilder Personal, after the scan code was scanned, the AppyBuilder application on my smartphone crash: it quit automatically.
Why?


#34

I find a workaround: I am entering manually the code so I can connect.


#35

I’m totally lost here!
I don’t know anything about coding that’s why I’ve been using the online platform.
Please how am I to create apps again through this offline platform.
Please help me!


#36

Read the entire post. You’re gonna understand the proccess of installing, using and generating APK with Appybuilder offline.


#37

Thanks.
I just did it & it’s still telling me “Build failed! connect error: Connection refused: connect”
What do I do next?


#38

This message means that either your are using the online version ( http://gold.appybuilder.com ) or you are using the offline (http://localhost:8888/) without starting the build server . In offline version WinStartFrontend.bat starts the frontend server and WinStartBuildServer.cmd starts the build server. So in order to create .aia and build .apk you must run both servers


#39

Hi,
thanks for tutorial.
After downloading and unzipping the folder I am getting following error:
My Java version : jdk1.8.0_221


#40


Please where am I getting it wrong?
WinStartBuildServer & WinStartFrontend open & closes immediately