Importing apps from Silver into GOLD



To import apps from SILVER into GOLD, please follow instruction below:

  1. Download Silver .aia from silver platform
  2. Use ONLY 7-zip to open .aia - DO NOT extract, just open it and keep it open
  3. Once .aia is opened, drill down the src folder all the way till you see your Screens
  4. Drag and drop all screens into a temp folder on your computer (keep 7-zip open)
  5. Now drag and drop all screens from temp folder into notepad++
  6. In notepad++ do control-h to for “find and replace” (see HERE for detail tutorial)
  7. Select “Find in Files” tab and enter the full path for the temp folder that contains your extracted files
  8. You’ll need to perform “Replace in Files” for all following:

Replace VSVArrangement with VerticalScrollArrangement
Replace HSVArrangement with HorizontalScrollArrangement
replace ProgressDismiss with DismissProgressDialog
Replace ProgressShow with ShowProgressDialog
Replace SelectionFullPath with Selection

After these updates are made, then drag and drop all files back into 7-zip

Companion error
Elements of new screen are dwarfed
Squished app fix?
I imported app inventor project to appybuilder
Why can not I create my application?
Free.appybuilder doesn't compile any project anymore
Can't upload project created in Free plan into Gold
Penguin Egg Schedule
Error to open project migrated from silver

i have an error:

A problem occurred while loading this project. Unable to load project with VerticalScrollArrangement version 2 (maximum known version is 1).


Did you follow the tutorial?



the app is work, but when i open the project appears this error. I work it and i can build apk.

is as a warning


best to best tutorial


How was the tutorial


I followed this tutorial to import an old project but I received the error: A problem occurred while loading this project. Unable to load project with HorizontalScrollArrangement version 2 (maximum known version is 1).

Although the project seems to open fine and I receive no other errors a part from some property name that probably has changes through time (I see the warnings in the debug panel).

Can I ignore the above warning?


Try to do save and reload and check to see if you still get same issue. If yes, then I’ll fix it for you.


Gold Is The Best old is old gold is gold


I’m getting the same error every time I open the project right after login in AB.


@Gabryk I replied to your PM and attached your updated .aia
Give it a try