HTTPS for Web Component


#3

Thanks @Nickon Seems error is with the specific URL i am using. Other HTTPS urls work fine.

My error with the URL is "Unable to get a response with the specified URL: HTTPS URL here "


#4

I have an api server with https, works fine. I hope yours will work too…


#5

It sounds like the https URL isn’t being stored properly, if the actual error message includes “HTTPS URL here”.


#6

The same URL opens well in a browser. But throws the error when I do a GET from web component.


#7

That means probably the problem lay in the blocks. I think if you post your blocks here, it would be easier for people to help.


#8

Below are the blocks.

image


#9

I see you’re hitting port 8443. Can you verify that the web component works when non-standard ports are specified on other sites?


#10

Yes @Thomas_Leavitt it works for my other http URL with port 7051.


#11

Hmm… puzzling. Are you running HTTPS on that port (7051) as well? Anything unusual about the content of the 8443 URL?


#12

No, http on that port (7051)


#13

Maybe the component specifically has issues with SSL on an alt port. I’ve seen weirder bugs. Try testing it on a different server where https runs on a non-standard port. That will be useful info to know, even if it works.


#14

Sorry I don’t get this. But I think it’s an SSL issue. When I use same URL in the webviewer, it works only when I check the box for Ignore SSL errors.

Any help to get this working with web component will be much grateful.


#15

Well, that’s a clue.

The port you’re accessing appears to be a web socket (tried hitting it). Maybe you should be using a web socket component to access it? Strongly suspect this is an issue with the content at the specific URL you’re trying to access, and unrelated to SSL or the web viewer component in particular.


#16

Where can I get a web socket component please. Any extension available?


#17

@Taifun maintains a list of extensions here: https://puravidaapps.com/extensions.php

This sounds like what you’re looking for:


#18

Forgive my ignorance but I have no idea what web sockets are or how to use them.

I only need to pass some GET parameters in the URL and receive a response which I work with in the app.

Any guide on how this web socket thing can help me do that.


#19

No idea, never actually done web sockets programming, but if it’s a web sockets interface, then a web sockets specific client component, logically, should allow you to pass parameters and get a response and possibly bypass these issues, if the server itself isn’t somehow misconfigured.


#20

Hi So the problem is that Web component doesn’t have Ignore SSL errors option like the Webviewer component has. This is helpful with working with URLs with private certificates like what I am working with.

This ignore option for Web component is on the to-do list for App Inventor but it’s been a while and I’m not sure when it will be done.

Any extension devs willing to help out here, please?


#21

Hi, why dont you repair the error on SSL or anything like that? I mean, the error is in the SSL. If not, just turn off your SSL and then you can redirect your domain using Cloudflare. You will get free SSL.


#22

Unfortunately, that is out of my hands. The domain and API belong to my client who uses this for other services as well so cant make such changes specifically for me.