How to use .RequestAppPermission?


#21

it was working fine before this new release, and i don’t like the internal sidebar.


#22

@Hossein, with ImagePicker if I deny the permission

And select an image with ImagePicker the app crashes.

Is it possible to add an event block for permission granted or a default popup stating that the permission is required and if denied a 2nd time close the app?

ImagePicker.aia (990 Bytes)


#23

yes this is my second problem, you pointed out earlier,


#24

Now do some changes in your aia file and you will get my problem.
Add another Screen.
add a clock component in the first screen.
set interval to 1500,
and open the second screen after clock1.timer event. put an image picker in the second screen.
you will get my problem.


#25

and then give me a solution,


#26

@Ken thanks for sample .aia. We’ll check it out


#27

I did that but I don’t get the same results as you however, it does create a less than desirable result.
ImagePicker.aia (2.1 KB)


#28

Hello sir I have also same problem when screen 1 initialize ask permison for media storage but when register screen initialize no permison ask and when click register and that came .Please help me as soon as possible I want update my app on play store .

I am using colintreeIMEI,Taifunclipborad,dialogs that’s all


#29

@Jeet_Info,

colintreeIMEI would probably require that Permission.
Call the Screen1.RequestAppPermissions block before trying to access phones IMEI:
Screenshot_20180731-183839_Chrome


#30

yes i set this block before but same result and no permision ask


#31

Sir I done this before and when I set this block no permison ask


#32

I think what’s happening is that app tries to get permissionS (using RequestAppPermission), then it just continues to other blocks. Again, we added this block for those who are using extensions that uses permissions like storage/camera/etc. I can think of a way to resolve this, but seems like it’ll require another release


How to solve this Problem?
#33

can i give the aia to you for look upto it


#34

When you make new release


#35

Me sucede los mismo.


#36

Me sucede lo mismo, y necesito actulizacion para play store


#37

So, do you have any solution ??


#38

I’m very disappointed, I worked on an App so hard and spent a lot of time, when it was near to complete it is getting crashed. :cry::cry::cry::cry::tired_face::disappointed::disappointed::disappointed:
Please provide an event (new Block) that should be triggered when user interact with permission dialog so that we can continue our blocks accordingly. And provide as soon as possible because no App will work correctly.


#39

Possibly because I used more blocks, you may have that crash if you use more blocks as I. but definitely the problem is there.


#40

@Hossein I’m stuck and i don’t have any solution. I’m waiting for an event block of .RequestAppPermission or just remove this feature the old version was fine. I’m just looking my App :disappointed::disappointed::disappointed::disappointed::disappointed::cry::cry: how much time will it take to fix ??