How to disable Web component default error alert notification?


#1

I wanna disable web component default error alert notification. Web component has the tendency to show alert, whenever the component is unable to get the specified url so here the problem is the url got exposed and yea I don’t want this type of alert so now the million dollar question is how can I disable Web component default error alert notification?


#2

Check out:
OnErrorOccured


#3

Nope Ken…It’s not extended web view extension. I am talking about Web component from the connectivity section of the appybuilder.


#4

I think you missed what Ken posted…

That extension has an OnErrorOccured block that would allow you to trap the error of the built-in WebViewer and then give you control over what is displayed to the user.


#5

I am talking about this…:point_down:
thisImage


#6

USe this and filter out the Web components.


#7

I misread, I thought you meant Webviewer…

This is how I handle Web Component:

If Web1.responseCode != 200:

And I use the same method as @Cian_O_Sullivan for 1101 Errors:


#8

I can do that with the help of network manager component…I know it’s kinda solution but still no option to hide or disable default notification.


#9

Because I’m intercepting everything but a responseCode of 200, I don’t see the default notification.


#10

will this extension work in Kodular?


#11

The Extended Web Viewer Extension?
I don’t know for sure but I assume it would…


#14

Decide which builder to use then ask questions in that community, asking questions here about other builder is not fair…

/Boban