Horizontal Arrangement not appearing bug?


#1

Hi all,

I have a game with a vertical arrangement called ‘play’ - Within the play arrangement are several vertical & horizontal arrangements. There’s one horizontal arrangement, however, that is not displaying anything at all!

When I set the ‘play’ arrangement as visible and download the apk, the above horizontal arrangement appears how it should, but when the ‘play’ arrangement is made visible by clicking on play via the menu arrangement, everything else appears except for this one horizontal arrangement!

Is there something simple that I’m missing or do you need more information from me to help? I’ve literally stripped away any splash screens I had to see if something there was causing the issue, but no luck.

thanks

James


#2

We can’t possibly know what’s going on in your app because we can’t see it.
Post it or post images of your designer/blocks.


#3

error

The first one shows the only blocks between screen initialising and the Play vertical arrangement being made visible. The second screenshow shows the particular HA that doesn’t display when the Play arrangement is opened through the blocks.

thanks in advance

James


#4

Try this

/Boban


#5

Hi Boban,

thanks for offering a solution. Unfortunately, it still doesn’t display this one element (named: Question (Horizontal arrangement)).

The clock seems to be behaving properly, as every other element is displaying on the play arrangement :confused:


#6

I see that you are using a Vertical Arrangement as your main arrangement. This type of arrangement wont display all the contents if the contents surpas the screen size. Try replacing the “Play” arrangement to a Vertical Scroll Arrangement to see if that solves the problem.


#7

Thanks for your suggestion. I’ve changed the play arrangement to a scrolling arrangement, but unfortunately, the ‘question’ arrangement still doesn’t display, just a blank gap where it should be! :confused:


#8

Only way to find out what’s wrong is if you share your aia

/Boban


#9

Hi all,

Just to let you know, I seem to have sorted the issue I was having! Where it says ‘screen1.width’, I had ‘question.width’ - Not sure why it wouldn’t have worked using the width of the question HA, but i’m happy to have it resolved now!

thanks all for your time

James