Help for the error after the last update


Ooops! We tripped on a Bug!
Please help us by telling us what you were doing at the time this happend. We have already included some technical data with this report. If you do not submit this report, nothing will be reported to us. If you do submit a report, your comments along with the technical data will be sent to us.

Thank you for your help in making AppyBuilder better!
After the last update of March 7, 2018 when I try to run my app from the companion or download the apk I get the following error message:

Technical Data to be Submitted:

notes = Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36
foundIn = none
faultData = (TypeError) : Cannot read property ‘type’ of null
projectId = 5311197555458048

I sent the report. What could it be? I do not understand which component it could refer to. Thank you all for your help.


It may be cache issue. Try switching browser. Does the project exist in list of your projects?


Thanks for the reply, I tried to clear the chrome cache, but it does not work. I tried to work with firefox, but the same problem. The problem also occurs when I try to generate the apk.
I suspect it may depend on this update:
"Feature: Screen: Added block: SetTitleBarCustomFont for changing titlebar font"
But I can be wrong.


Name of project is “gestmaga” , thanks


What happens if you remove that block?


No, I did not put that block. I thought it might depend on that because I read that it was added. I worked until before the update. I can also take a test and recall a project saved the day before the update to see if the problem was born with the update


I understood the problem. It’s the new “spacer” component if you change the color makes the app go wrong. In Designer there is the possibility to set the background color, but in the missing block editor, there is probably a code error.


Interesting. Good funding. We’ll check. Thanks for reporting


We intentionally didn’t add block for color because it it doesn’t make sense to have that block


but it could have it, in fact I wanted to use it as a separator, even if in essence I get the same result with the label component


Verified. Changing color causes build issue. We’ll fix this. Please don’t change background color till bug is fixed.