Google changing minimum target API level


#21

you might want to elaborate…
what are you trying to do? what do you expect? what do you get instead? also relevant screenshots might help us to help you…

Taifun


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.


#22

Hi Taifun,
ok i come from AI2U and now i should like to use AB, i have already 2 app on GPlay and i should like make some upgrade (26 API too) and other thing like add sidebar ecc. I imported .aia to AB, add a sidebar and packadge font, remove all extension, minsdk 14 or 16, targetsdk 26, build apk, signed with AppToMarket but on my Note2 (kitkat) don’t run instead Nougat and Oreo apks work. I’ve already done all the tricks proposed by Boban, apk don’t work befor AppToMarket and after signed with ATM too. As i said on AB in live test on my kitkat everything work. I don’t know what screenshot to post… maybe manifest… ah! i tried to do a new simply project but nothing same result, when i tap on icon after 1/2 second show me “the program has been arrested”.
Let me know exactly what i can be useful to help you.
Thanks
Regards


#23

Since it’s live test but does your apk works when you download it from Appybuilder

Edit, did not see this

When you decompile your apk, open this file apktool.yml and look for what is there, should be this

/Boban


#24

Hi Boban!
no don’t work…
…build apk (from AB), signed with AppToMarket but on my Note2 (kitkat) don’t run instead Nougat and Oreo apks work. … apk don’t work befor AppToMarket and after signed with ATM too


#25

:grin:
i didn’t see the rest of your post… i was on smartphone… sorry.
ok, now i’m working, this evening i’ll observe .yml and will refer you.
Thank Boban have a nice week end
Regards
Angelo

p.s. I had already looked at .yml file some days ago and if I remember correctly it was correct… but this evening i’ll check it


#26

Hi,
apktool.yml is correct.

and this is manifest


#27

At the moment I have no working phone with Android below 5.0

The reason why

I will try to test on emulator however, I do not rely heavily on them

/Boban


#28

this is strange too… :roll_eyes:
kitkat on left e Nougat on right


#29

Looks like it should

uses Holo Theme

uses Material Theme

/Boban


#30

Thank Boban for info!


#31

Btw, does a simple projekt/apk work on your kitkat without extreme components such as Firebase, Onesignal, Package name etc.

/Boban


#32

it run… mmm maybe there is something that is incompatible… now I try and hope to post the solution


#33

Just a hunch but it seems that your package name is somewhat off and you probably should not use words as android

/Boban


#34

i tried to delete ApplicationPackage but nothing.
maybe progress bar? or sidebar?


#35

Sorry, I’m clueless

/Boban


#36

If you’re in the Builder, delete the ApplicationPackage, goto File > Save, then refresh and build again.


#37

Maybe i found the problem. If I put a switch, on kitkat app don’t work, if I remove it app run. Can anyone try to confirm this problem or not?
Regards


#38

Thank Meteor I already tried it but it didn’t work anyway.
regards


#39

Sorry, when you are tired and have dumb humor

curious by whom :policeman:

Btw, try with default configuration, no color change or so

/Boban


#40

arrested
from Google translator :rofl::rofl::rofl: maybe stopped?
I’m too old to learn English