Error: Argument (package forrange-with-break)

bug

#1

Hello to all! I’m having this bug since today (saturday my app was working fine)
It says: Error from Companion: Argument (package forrange-with-break) to 'apply-to-args' has wrong type (java.lang.Package) (expected: procedure)

Any ideas on what to do? I haven’t changed the Package name and I don’t see any procedure misplaced or without any sockets un-filled. It appears to happen, only when using the for each number from 1 to 5 by 1 block. Also, I have reconnected the companion, and refreshed the page but it keeps appearing.

image

EDIT: It also appear when using for each item in list block and while test do block.
image

Also, I think it does what it needs to do, but only one time (the first loop)


Is there anybody have the same issue?
Problem after compile app: unbound location
#2

Did you get companion 4.05?


#3

No, I didn’t :sweat_smile: I will try again!


#4

It works! Thank you!


#5

If I build the apk, now it appears the same error:


Problem after compile app: unbound location
#6

Yes I got that error too.

Works fine in companion but error after I build it.


#7

i also have the same problem: "unbound location forrange-with-break"
it seams that there are problems with the for each loops…


#8

i get almost the same but:

foreach-with-break.

yesterday i didnot have this problem and now i haven maybe the update from yesterday something wrong with?


#9

i change it to app inventor. there is no problem


#10

The developers are still looking at the problem but it is night where they live so please be patient.


#11

Yes, As Peter mentioned, we are working on this and are fixing this. We thank you for your patience


#12

Only for information:
I have the “unbound location foreach-with-break” problem too.
Wait for fix. :wink:
Greetings
Thomas


#13

@TF101, don’t worry, this bug is known.


#14

I know
I meditate meanwhile :wink:


#15

We have a software update and will be testing with markets who joined the power users group. After that, if approved, we’ll push the release publicly. I you have experienced this issue and have a app that you can test, you can join the group:


#16

Hi,
I’m having this bug too since yesterday.
There is any update when the fix will be
released?
Thanks


#17

Hi,
I’m having this bug too since yesterday.
runtime error “unbound location foreach-with-break”


#18

same error here “unbound location foreach-with-break”

whats happening?


#19

The same mistake for me


#20

tengo el mismo error y necesito generar el apk para un proyecto :pensativo: