Decompilation of apk's has stopped working


#1

Good morning,
I have found out something strange with apk’s built by Appybuilder Gold.
When I try to decompile an apk. it cannot be decompiled anymore. It produces the next error:

04nov2018_0757.32: Your Platform: windows 10
04nov2018_0757.32: Java Version: 1.8.0_191
04nov2018_0757.32: AppToMarket Version: v4.1
04nov2018_0757.32: Install folder: C:\Progs\ApptoMarket2
04nov2018_0757.32: Your data was loaded from: C:\Progs\ApptoMarket2\resource\config.txt
04nov2018_0757.43: BUTTON CLICKED: 1> Decompile
04nov2018_0757.43: I: Using Apktool 2.1.1 on Bingo.apk
04nov2018_0757.43: I: Loading resource table…
04nov2018_0757.43: I: Decoding AndroidManifest.xml with resources…
04nov2018_0757.43: I: Loading resource table from file: C:\Users\Eric\apktool\framework\1.apk
04nov2018_0757.44: I: Regular manifest package…
04nov2018_0757.44: I: Decoding file-resources…
04nov2018_0757.45: I: Decoding values / XMLs…
04nov2018_0757.45: ERROR: Unable to decompile your .apk file

When I use an older apk (2017), built by by Appybuilder Gold, the decompile process does work.

04nov2018_0750.41: BUTTON CLICKED: 1> Decompile
04nov2018_0750.41: I: Using Apktool 2.1.1 on SunriseSunsetTest2.apk
04nov2018_0750.41: I: Loading resource table…
04nov2018_0750.42: I: Decoding AndroidManifest.xml with resources…
04nov2018_0750.42: I: Loading resource table from file: C:\Users\adam\apktool\framework\1.apk
04nov2018_0750.42: I: Regular manifest package…
04nov2018_0750.42: I: Decoding file-resources…
04nov2018_0750.42: I: Decoding values / XMLs…
04nov2018_0750.42: I: Copying raw classes.dex file…
04nov2018_0750.42: I: Copying assets and libs…
04nov2018_0750.42: I: Copying unknown files…
04nov2018_0750.42: I: Copying original files…
04nov2018_0750.42: SUCCESS: your .apk was decompiled into: C:\Progs\ApptoMarket2\temp_myDecompiles

I have tested it with different apk’s today. Even a simple apk I made today, with just one label, does not decompile anymore. Older apk’s, from this year, also do not decompile.

But testing some older apk’s from 2017, the decompilation process works fine. :+1:t2:
I am using AppToMarket v4.1.

Thanks,
Eric


#2

I tried it here and it still decompiles. I changed the category to apptomarket.

http://www.javadecompilers.com/apk


#3

I have tested it too. It decompiles fine with the online decompiler. It seems to be AppToMarket that makes the problem.


#4

Yes, that seems to be the case. That’s why i changed the category.


#5

http://baasapps.com/tips-and-tricks/#apptomarket170


#6

Thanks for the tip Hassan, but the decompilation does not work in AppToMarket (only).


#7

It still works as it should.

/Boban


#8

@Boban. Just made an app and an apk in Chrome (Firefox before, but with same result). AppToMarket cannot decompile it.
Test_AppToMarket.aia (1.0 KB)


#9

Did you follow the instructions from the link that @Hassan has provided you with.

/Boban


#10

I just tested your aia. It SUCCESS


#11

Hassan, could you please test the APK I have made, to see if it is a local problem?
I have put my apk example in the cloud. See the next link.
https://ericdemagier.stackstorage.com/s/u5HnABrfG1h29ky
(download is available till the 1st of december 2018)


#12

05nov2018_1745.17: BUTTON CLICKED: 1> Decompile

05nov2018_1745.17: I: Using Apktool 2.3.3 on Test_AppToMarket.apk

05nov2018_1745.17: I: Loading resource table…

05nov2018_1745.21: SUCCESS: your .apk was decompiled into: C:\Users\Boban\Documents\AppInventor\AppToMarket\AppToMarket_v40\AppToMarket_v40\temp_myDecompiles

/Boban


#13

Thanks Boban :+1:t2:. Now I have to find out which (missing) software part is the trouble maker.
Do you have tips for the Java (runtime environment) to check, or the version(s) that need to be installed, or version(s) which better should be avoided?


#14

Do you still get this in your decompile history

/Boban


#15

@Boban_Stojmenovic the detective :sunglasses:

Detective_looking_through_magnifying_glass


How to send mp3 files?
#16

:rofl::joy::laughing: @Peter that was a good one

/Boban


#17

I searched for APKtool and found a newer version: v2.3.1
I had to rename it to: apktool_2.1.1.jar. (No clue where it can be changed in a config file that the right version can be choosen).
05nov2018_2010.03: I: Using Apktool 2.3.1 on Test_AppToMarket.apk
After that I was succesfull in decompilation and all the recompile steps.
Thanks Boban for that clue. :tada:
And yes Peter, programming is an eternal search for bugs. :smile:


#18

If you had done this from the very beginning and followed the instructions on my website…

You would have avoided all this trouble long time ago.

Btw, FYI newest version is 2.3.4

/Boban


#19

That’s funny.
And thank you @Boban for the instructions.


#20

Which part?

:star_struck: you’re welcome.

/Boban