Companion kills my phone

bug

#1

Hey guys,
I’ve normally connected the Companion. It was the new version (5.07) but companion still said it needed an update. However, on the Playstore there was none… Isn’t 5.07 the newest?

Now the strange thing happened:
While testing my app via companion, the screen went black. My music was still playing but i couldn’t do anything. The only thing i could do was clicking on power and restart/power off. I tried restarting and it booted until normally the “SIM Login” screen would show but it didn’t.
I went into Recovery and wiped the cache. Did nothing.
Then I wiped the system settings and cache and this worked but it killed all my data. Needed to setup my phone again…

I thought it was a one time thing but now it happened again…
This is very strange… Don’t know what to do. Don’t want to setup my whole phone every time I am coding… :smiley:
I cannot even send you logs. Nothing is working…
Anyone knows what to do?
Cheers


#2

Hi @marv,

Thank for coming to the Appybuilder community! Here’s the thing, the latest companion latest is 5.07, it will show you a dialog after connecting the companion that it’s not the latest, but the Build server was not updated so that’s why. Please wait until @AppyBuilder can get to your concern.


#3

Are you testing a heavy app??? maybe the RAM of your phone is overloading.


#4

Nope. Nothing heavy at all. Also 8GB Ram should be good. :smiley: