Clock has a problem after the last update


#1

The clock is not working properly. I compiled the same .aia file that worked before and now does not work after the update. The worst that presents no log to post here the problem is that sometimes it works sometimes not. This intermittent bug. I’m posting to other users to see if they have the same problem.


#2

#3

I also have the feeling that something is wrong with the clock component in older aia.
I could solve it by adding in addition to
Set TimerEnabled to True

a

Set TimerAlwaysFires to true

Thomas


#5

You saved my day … It worked fine by setting all the clocks for TimerAlwaysFires to true.
Many thanks to my friend!


#6

I’m glad it works. But do not forget :
Set TimerAlwaysFires to false If the timer has done what he should do.

Kind regards
Thomas


#7

Okay. Thanks! :hugs:


#8

I have this same problem. All my apps that use a clock to display the splash screen no longer work. The splash screen just hangs. Have tried the above fix, but doesn’t work. I have attached a screen shot of the blocks and clock settings. If someone can help I would appreciate it as I use this same format on all my apps. I also use the clock in other places in some of my apps, like for the login pin screen. These also no longer work, but they used to.

Clock-Settings


It seems Clock Component Not working Properly
#9

You don’t have “TimerAlwaysFires” set to “true”, set it to “true” when enabling the timer and “false” when you disable it.


#10

I have a doubt, if I use the clock component, I always have to use TimerAlwaysFires in true?

or is it not necessary?

my application performs a task of checking data every 30 seconds and for me it is important to open a second screen with the clock component of screen1 always working.

I can not with this problem, whenever I open a screen I randomly throws a component error or screen not found.

I’m getting bored with this flaw and I can not release updates to my app like that, a few days ago I launched an update and I’m losing users. please help.


#11

Patience is the only thing that can help.


#12

unfortunately the problem has not been solved yet, and frankly I don’t even know if they will solve it (since only a few users complain about this problem), I solved it for now … using appybuilder offline, also seeing that offline function and the same identical .aia with the “online” version does not work, this shows that there is a problem!


#13

If you do this every time you start the clock, the problem doesn’t happen:

image


#14

No funcióna en todos los casos…


#15

Excuse me, can you clarify this for me?
The application timer is initially disabled, this is understandable.
If I need a continuous cyclic timer (for example 30 seconds)
Should I include TimerEnabled and TimerAlwaysFires to “true” every timer step or is it enough to set them once?


#16

Only set it when starting.