Can't Import TaifunFile extension [solved]



every time I try to import a new extension I got this error and my screen set to blank what can I do? the error code is in the link


@tulsi_das_bohra for testing, have you tried importing other extensions?


Yes I’m use 3 extension
1 sidebar
2 taifubfile
3 call loger


…them i wouldn’t tag this as bug :slight_smile: you may want to contact extension developer to track down the issue. Also, make sure that after importing any new extension, you kill and restart the companion.


How can i contact extension developer.?
And I can’t use any external extension


You can import external extensions. Try to narrow down error. For example, import only sidebar extension. Kill and restart companion. If it works, then next extension…


How to avoid runtime errors with the companion app

After importing an extension, please restart the companion app. If you like to use an extension on a different screen, in Screen1 additionally drag the extension into the working area.

While starting the companion app, all necessary assets and also the imported extensions of your project will be copied to your device. So in case the no such class error shows up, the extension code to run the extension is not available on your device. Without that code the companion app is not able to execute methods from the extension.



Actually no, this is a known bug. My extensions cant be used too, and I have given a notice to MIT Team, you can check GitHub App Inventor’s repository and check issues tab. Regards.
P.s: this happens not only with companion, but also when you try to compile apps.


@Ben please include issue link



On companion you get RuntimeException and on compilation ClassNotFoundException. Tested with 2 extensions of mine


I wonder what has changed. So this happens only for some extensions??


Yeah, my extensions are built same every time. Sometimes I build extension and it works and sometimes not. Also, usually I have to rebuild extension at least 15 times, but sometimes I just can’t make an extension at all…


I have to disagree…
the last version of the file extension has been built on Sept 10th and was working fine up to now…

@Ben @tulsi_das_bohra you might want to provide an aia file which uses the file extension, so someone else can test



Now working fine just import extension close website and open again and extension work perfectly


Well, maybe for you. Have you updated your sources with latest version? I can pass 2 ext for you, both give same exception just like in GitHub issue. Did you try compiling multiple ext at the same time? While we have different opinions on that. As far as I have seen, there is multiple extensions that give this error. I have made an extension, SystemAlertWindow (as you know), which somehow users can’t ise because of this exception. Regards, Ben