AppyBuilder status update


#105

I did pull (with tortoise GIT) but then now appybuilder offline cant import my aias (server error: could not upload project. Please try again later!).
Before pull new version, every time i tried it worked well.
Anyone knows how to fix it or how to return to previos version with tortoise git?


#106

Hello. I did everything according to your instructions. Checks in the command line showed everything OK. But when I click on the WinStartFrontend file, I get the command line window again and it doesn’t work. Please, give me an advice. Thank you


#107

From your image it looks like your frontend server is running - INFO: Dev App Server is now running. If you open your browser and type localhost:8888 what happens ?


#108

When I enter localhost: 8888 in the browser, links to other pages will appear. :frowning:


#109

You have a space between localhost and 8888


#110

Thank you very much for the warning. It works now.


#111

So unfortunately, if I want to save the application to my computer, it will write me build failed. :frowning: Please advise me.


#112

You have started the frontend

Starting frontend (user interface)

Use File Explorer to switch to the new folder (AppyBuilderPersonl) Next, double click on WinStartAppyBuilderServer.bat to start the frontend (or equivelant .sh file) IF the popup window immediately closes, this means that your java path is not setup properly You may have to update the file to directly point to your java.exe; e.g. C:\Program Files\Java\jre1.8.0_121\bin\java.exe

At this time, you can start a browser, and enter http://localhost:8888

How about do the same with backend

Starting backend (build server):

If you are attempting to build .apk, you’ll need to start the local buildserver Use File Explorer to switch to the new folder (AppyBuilderPersonl) Next, double click on WinStartAppyBuilderServer.bat to start the buildserver (or equivelant .sh file)

/Boban


#113

I think the Java path is set correctly. I attach a picture. And when I click on WinStartFrontend, the picture below is displayed. And when I click on WinStartBuildServer, the cmd window appears for a second and disappears immediately. Please advise what I’m doing wrong?



#114

Frontend server runs in port 8888 and since you can start it we can assume that Java is set up correctly. Build server runs in port 9990 so maybe another app is using this port


#115

So I only have a port in port 8888. So what should I do?


#116

I’ve already figured it out. I downloaded the wrong version of the Java Development Kit before. Now I downloaded the right one and everything is working for me. Thanks


#117

I’m not sure this designer properties shown is for app builder Google Map component. We have issues with Google Map.


#118

am using the offline version.
But I still cannot build an apk.


Please help me.


#119

Is build server running ? If not run WinStartBuildServer.cmd


#120

Am actually using Macbook
And the only commands I can type is ./startFrontend.sh
./startBackend.sh


#121

Use

[quote=“cherrymarshal, post:120, topic:29320”]
startBackend.sh
[/quote
/Boban


#122

If you share your Terminal screenshot for the ./startBackend.sh, maybe someone will be able to help you. The script may show if there is any issue.


#123

Thanks everyone it’s solved


#124

I have been able to get it working
Thanks