AppyBuilder status update


#63

Same thing happens to me , if I choose to save apk to computer works ok, otherwise if I choose Qr code I receive the same error


#64

@delavitta @dora_paz use your computer’s ip:port instead of localhost:port

/Boban


#65

Its not enough @7starmedia monetization component is not good enough need designing component mostly


#66

@7starmedia API 28 is already implemented in offline version


#67

Thank you . I used my ip 192.168.xx.xxx:8888 instead of localhost:8888 and works fine


#68

I added this to the Tutorial: Installing AppyBuilder Personal (offline version) via Git

Thank you @Boban_Stojmenovic


#69

I tested my project. I focused to API 28 but admob is still doesn’t working.

When trying to load:
For RewardedVideo i got “Internal Error”
For Interstitial i got “Something happened internally; for instance, an invalid response was received from the ad server.”

Also i have a problem with Build.
I tried to build save apk to my computer or qr code . Sometimes i got a line that says “Packaging…” SOmetimes not, but i always got this error:
" Build failed! Build server responded with response code -1."

This is what it in the Buildserver CMD

And this in the frontend


#70

Buildserver uses port 9990. Seems like that port is already in use by other processes


#71

Thanks you!
I dont understand much of these, but seing a tutorial i tried to catch what is using port 9990.

In windows in cmd used the command netstat -o (wich gives ports and proccess ID) and port 9990 doesnt appears i tried before and after running startbuildserver.

Wich netstat -a it appears as listening. I tried before and after startbuildserver and its the same
imagen .

Any clue on what to do?


#72

I windows run resmon.exe, Resourse monitor will open . Go to listening port and see if another program is using port 9990 . Currently I run both servers frontend and build so you see that java.exe both in port 8888 and in port 9990 . When I close the servers I do not see those ports in use


App not build plese help me
#73

@Hossein @dora_paz
Thanks You! I managed to use it.
This version is wonderful! I could upload my project with all the assets inside it!

The only thing is with the admob that is not showing ads…
Any clue if its mines problem or has something with the actualization of api level?


#74

That’s great that you were able to use the offline version


#77

Sad news about the online builder. We hope that when you return you will be full of news!


#79

Any idea why would the frontend work but the backend starts and stops immediately? I had already fixed the java home directory the same way for both.

thanks


#80

Maybe the ports are used by another app, frontend server needs port 8888 and build server needs port 9990.


#81

Thanks for sharing. Any idea how can I fix it? I am not very adept in these . . :frowning:


#82

Windows or Linux ? For windows see below


#83

Windows. Thanks. Hope this solves it !


#84

checked … nope its not blocked… this is the issue i get :
error


#85

This message indicates a Java memory problem . Go to Start->Control Panel->System->Advanced(tab)->Environment Variables->System Variables->New:
Add Variable name: _JAVA_OPTIONS
Variable value: -Xmx512M

Try if this solves your problem


Installing AppyBuilder Personal (offline version) via Git
WinStartBuildServer Error occurred during initialization of VM?
Can't start buildserver