AppyBuilder Offline



Changing the default application size limit in the offline version is fairly simple, I think that’s been discussed elsewhere either in this thread or on the forum. As have many options for working around the limit, including loading media from the web on initial start up. Usually, if your app winds up exceeding that limit, a thoughtful examination will reveal ways to reduce the size without actually limiting functionality. It is very easy to write apps that use memory and storage space inefficiently.


i am using ubuntu 17.10 and everything works fine. but when i try to add a new screen it is not adding rather displays ‘Server error:could not add forms, try again later’.
what should i do to rectify this.


@Thomas_Leavitt thank you thomas for your answer but can you suggest a way?


Please search the forum. This question has been asked many times and answered.


Awesome offline appybuilder,but why still has this 10mb,could you please how can i change this on the offline appybuilder which i downloaded from here?


Is it giving error for +10mb?
Also, a word of caution: don’t use offline for production. According to Google app engine, the database isn’t stable and you may lose your data


yes it giving error,it says:Build failed! Sorry, can’t package projects larger than 10MB. Yours is 14,91MB.

my aia is 14.8mb


That is a catch all message and misleading. Error could be somewhere else. Browse through entire log


i started the WinStartAppyBuilderGUI not WinStartBuildServer because its not opening also on the console it says the same thing,i used and alot of extensions does it matter?


I think the solution to this problem is due to your java version. I re-installed the JDK by downloading the jdk-8u161-windows-x64.exe file. I was using the jdk-8u161-windows-i586.exe installation which i think caused this problem. Problem solved since i installed the later version of the jdk. Then you also need to setup your JAVA_HOME path to access it. It works for me let me know if it also works for you.
Good Luck


Sir is there any chance to release updated offline version


oh yea sorry i didn’t post this here earlier. Actually i got it fixed a month ago… it Turned out the problem was with the Java/ jdk version. i am currently using jdk 1.7 and its working fine. the jdk 1.8 was the one giving me all the troubles and problems. Thanks For Also posting it here


Hi, All.
I have a plan to use Appy Builder Offline as the tools to teach mobile apps programming at school, replacing the online MIT AI2, since we have a low bandwidth internet connection.

But we have a problem with Appy Builder Offline which can’t use live testing to connect smartphone, if the access point can’t access internet too.

The access point have connected via the same switch with the PC, but without internet connection, the Appy Builder Offline run well, the smartphone have connected also with access point and get the local IP address. But when we try to connect via live testing, nothing happened and just end up with message “error 1103: can’t post … with the specified URL:”.

However, connection via USB run well. Also if the switch connect to the internet.


glad you figured it out


Would love to see some pictures of your classes using AppyBuilder


Setting up the offline stream seem to be difficult to the freshers.lot of them asks for the tutorial so, will someone or @PixiiBomb to make tutorial for “appy builder offline”?



usb connection not found within appybuilder offline in my win10 although usb is connected to pc successfully.
here the screen shots:


I’ve accessed localhost: 8888 but the same result still can not. do you use windows?


Hi Onniel,

I use Linux (Lubuntu)
Anyway, I believe that it can work under Windows if you keep track of the install procedure.
Also, If I’m not wrong, there is @Andres_Cotes package that make it all easy to Windows, packaging everything under an exe file that you can execute and make the things happen.
Here is the github adress:
I don’t know if it is still working, but, maybe, it worth a try.
If you want to install it all by yourself, I suggest start it over, from the scratch and follow all the steps.

May the force be with you


hi … can anyone help me to solve this?

and all bat files are closing whenever i open… plz help