AppyBuilder Offline

announcement
offline

#122

I don’t use Windows but Linux. I can only say that it runs on my system without any problems. I tried starting just the gui server but i got a different error when i was trying to build, not what you are seeing.


#123

@Peter_Mathijssen can I make offline apps with this help of appybuilder offline and is this latest version of appybulder
and what is the size of this


#124


its not opening


#125

I downloaded and extracted the zip file just yet and it works fine.

Maybe something went wrong while downloading. It says the archive is damaged. What if you try it again.


#126

@Peter_Mathijssen I have tried it much time but no worked so I download it again but it’s still not working so I used my 2nd pc to download and run but nothing changes and I have used much software like WinRAR 7zip not worked. I think its damaged need to update it


#127

Like i said. It is not damaged on Github. Something maybe is going wrong when it is downloaded.


#128

but I have download it again not worked. and also tried it on another pc it still


#129

I am using Lubuntu here (16.04 64 bits) and getting the same error.


#130

It is still working here. Just tested it again.


#131

I made my own zipfile. You could try this.

https://drive.google.com/open?id=1MtBYUc3WajWBAT-SvYuDSY4QOcoh_XWh


#132

@Peter_Mathijssen, thanks for your time and attention.

Being more accurate in my information, I’m using the Lubuntu installation in a Oracle VirtualBox (I supposed that this should not be a problem).
I downloaded your zip and uncompressed it. Changed the files permissions and started both servers from the prompt line.
After that, with the pcmanfm, I clicked on the “index.html” file, that is in the “GUIServer” folder.
I am still getting the error message (as you can see in the picture).
(

I’m using Oracle Java 8, for java compiler (I installed it with the apt-get). All the java environment is configured to Java 8. You can see the Java 8 compiler selected:

renato@renato:~/AppyBuilderPersonal-master$ sudo update-alternatives --config javac
There are 3 choices for the alternative javac (providing /usr/bin/javac).

Selection Path Priority Status

0 /usr/lib/jvm/java-9-oracle/bin/javac 1091 auto mode
1 /usr/lib/jvm/java-8-openjdk-amd64/bin/javac 1081 manual mode

  • 2 /usr/lib/jvm/java-8-oracle/bin/javac 1081 manual mode
    3 /usr/lib/jvm/java-9-oracle/bin/javac 1091 manual mode

Press to keep the current choice[*], or type selection number:

These are the messages when I started the AIServer:

renato@renato:~/AppyBuilderPersonal-master$ ./startAIServer.sh &
[1] 1937
renato@renato:~/AppyBuilderPersonal-master$ SDK_BIN is: /home/renato/AppyBuilderPersonal-master/AppEngine
Executing [/usr/lib/jvm/java-8-oracle/jre/bin/java, -javaagent:/home/renato/AppyBuilderPersonal-master/AppEngine/lib/agent/appengine-agent.jar, -Xbootclasspath/p:/home/renato/AppyBuilderPersonal-master/AppEngine/lib/override/appengine-dev-jdk-overrides.jar, -classpath, /home/renato/AppyBuilderPersonal-master/AppEngine/lib/appengine-tools-api.jar, com.google.appengine.tools.development.DevAppServerMain, --property=kickstart.user.dir=/home/renato/AppyBuilderPersonal-master, --port=8888, --address=0.0.0.0, /home/renato/AppyBuilderPersonal-master/GUIServer]


There is a new version of the SDK available.

Latest SDK:
Release: 1.9.61
Timestamp: Mon Jan 22 20:36:12 BRST 2018
API versions: [1.0]


Your SDK:
Release: 1.9.46
Timestamp: Tue Oct 18 23:22:06 BRST 2016
API versions: [1.0]


Please visit https://developers.google.com/appengine/downloads for the latest SDK.


fev 01, 2018 3:05:04 PM com.google.appengine.tools.development.SystemPropertiesManager setSystemProperties
INFO: Overwriting system property key ‘java.util.logging.config.file’, value ‘/home/renato/AppyBuilderPersonal-master/AppEngine/config/sdk/logging.properties’ with value ‘WEB-INF/logging.properties’ from '/home/renato/AppyBuilderPersonal-master/GUIServer/WEB-INF/appengine-web.xml’
fev 01, 2018 3:05:04 PM com.google.apphosting.utils.jetty.JettyLogger info
INFO: Logging to JettyLogger(null) via com.google.apphosting.utils.jetty.JettyLogger
fev 01, 2018 5:05:05 PM com.google.apphosting.utils.jetty.JettyLogger info
INFO: jetty-6.1.x
fev 01, 2018 5:05:08 PM com.google.appengine.api.datastore.dev.LocalDatastoreService init
INFO: Local Datastore initialized:
Type: High Replication
Storage: /home/renato/AppyBuilderPersonal-master/GUIServer/WEB-INF/appengine-generated/local_db.bin
fev 01, 2018 5:05:08 PM com.google.appengine.api.datastore.dev.LocalDatastoreService load
INFO: Time to load datastore: 125 ms
fev 01, 2018 5:05:08 PM com.google.apphosting.utils.jetty.JettyLogger info
INFO: Started SelectChannelConnector@0.0.0.0:8888
fev 01, 2018 5:05:08 PM com.google.appengine.tools.development.AbstractModule startup
INFO: Module instance default is running at http://localhost:8888/
fev 01, 2018 5:05:08 PM com.google.appengine.tools.development.AbstractModule startup
INFO: The admin console is running at http://localhost:8888/_ah/admin
fev 01, 2018 3:05:08 PM com.google.appengine.tools.development.DevAppServerImpl doStart
INFO: Dev App Server is now running

And these are the messages when I started the BuildServer:

renato@renato:~/AppyBuilderPersonal-master$ ./startBuildServer.sh &
[2] 1977
renato@renato:~/AppyBuilderPersonal-master$ Starting AppyBuilder BuildServer…
fev 01, 2018 3:05:20 PM com.sun.jersey.api.core.ClasspathResourceConfig init
INFO: Scanning for root resource and provider classes in the paths:
BuildServer.jar
CommonUtils.jar
CommonVersion.jar
FastInfoset-1.2.2.jar
activation-1.1.jar
args4j-2.0.18.jar
asm-3.1.jar
commons-io-2.0.1.jar
grizzly-servlet-webserver-1.9.18-i.jar
guava-14.0.1.jar
http-20070405.jar
jackson-core-asl-1.9.4.jar
jaxb-api-2.1.jar
jaxb-impl-2.1.10.jar
jaxb-xjc.jar
jdom-1.0.jar
jersey-bundle-1.3.jar
jersey-multipart-1.3.jar
jettison-1.1.jar
json.jar
jsr311-api-1.1.1.jar
localizer.jar
mail-1.4.jar
rome-0.9.jar
sdklib.jar
stax-api-1.0-2.jar
wadl-cmdline.jar
wadl-core.jar
wadl2java.jar
fev 01, 2018 3:05:22 PM com.sun.jersey.api.core.ScanningResourceConfig logClasses
INFO: Root resource classes found:
class com.google.appinventor.buildserver.BuildServer
fev 01, 2018 3:05:22 PM com.sun.jersey.api.core.ScanningResourceConfig init
INFO: No provider classes found.
fev 01, 2018 3:05:22 PM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Initiating Jersey application, version 'Jersey: 1.3 06/17/2010 05:04 PM’
fev 01, 2018 3:05:23 PM com.sun.grizzly.Controller logVersion
INFO: Starting Grizzly Framework 1.9.18-i - Thu Feb 01 15:05:23 BRST 2018
fev 01, 2018 3:05:23 PM com.google.appinventor.buildserver.BuildServer main
INFO: AppyBuilder Build Server - Version: none
fev 01, 2018 3:05:23 PM com.google.appinventor.buildserver.BuildServer main
INFO: AppyBuilder Build Server - Git Fingerprint: 4a8fdb592a90d33ed80c265ce0dc6ac1ff982b06
fev 01, 2018 3:05:23 PM com.google.appinventor.buildserver.BuildServer main
INFO: Running at: http://127.0.1.1:9990/buildserver
fev 01, 2018 3:05:23 PM com.google.appinventor.buildserver.BuildServer main
INFO: Maximum simultanous builds = unlimited!
fev 01, 2018 3:05:23 PM com.google.appinventor.buildserver.BuildServer main
INFO: Visit: http://127.0.1.1:9990/buildserver/health for server health
fev 01, 2018 3:05:23 PM com.google.appinventor.buildserver.BuildServer main
INFO: Visit: http://127.0.1.1:9990/buildserver/vars for server values
fev 01, 2018 3:05:23 PM com.google.appinventor.buildserver.BuildServer main
INFO: Server running

Where is my mystake? Do i have to install the GUIServer in a specific folder? Did I forget to do something?

Regards.


#133

@Peter_Mathijssen, I think i get where I was missing.

I was trying to start the GUIServer by starting the “index.html” under the GUIServer folder.

Noooooo… I was wrong.

It is supposed to me access my localhost. So, I pointed out to “http://localhost:8888/” and the magic happened.

I’ll try with my own package now.

Thumbs up to you, my fellow!!! And thank you for your attention.

Renato.

PS: sorry for the bad English - I’m a native Portuguese speaker :wink:


#134

I was going to answer this but you found out for yourself. Great :+1:


#135

So my zipfile doesn’t give the error you got from the appybuilder github page?


#136

Nope, no problems! It is working smooth!!! Congrats! :wink: and thank you again!


#137

I created an issue on the githubpage so that the developers can take a look at it.


#138

The original package is working also. I downloaded it again, and it is working fine (as you can see in the following screenshot)

For the AppyBuilder team, IMHO, I suggest that you include the “how to” or the “step by step for dummies” (like me :D) in the README.txt, in order to help the uninformed ones :blush:

Thanks for the wonderful work - surely it will be a revolution!


#139

I think that the problem is not the zipfile itself; instead, I was trying to start the application clicking on the “index.html” file. Maybe @Brainwork was doing the same (I don’t know).

I downloaded the original AppyBuilder file and installed it all again.
The servers started and I pointed the browser to the localhost:8888 and it worked (with the original AppyBuilder GitHub file).

So, the issue was on my side, not with the zip file.


#140

in the readme.md it says:

Starting frontend (user interface)

Use File Explorer to switch to the new folder (AppyBuilderPersonl)
Next, double click onWinStartAppyBuilderServer.bat to start the frontend (or equivelant .sh file)
IF the popup window immediately closes, this means that your java path is not setup properly.
You may have to update the file to directly point to your java.exe; e.g.
C:\Program Files\Java\jre1.8.0_121\bin\java.exe

At this time, you can start a browser, and enter http://localhost:8888

Maybe that should also be in the readme.txt


#141

I guess that makes AppyBuilder so special.