AppyBuilder Offline

offline
announcement

#1

Hello AppyBuilders,

We have released an offline version of AppyBuilder that can be downloaded from github repository below.
We will keep this repository in sync with the online version:


Appybuilder off-line @AndresCotes Version
AppyBuilder Release - Now FREE and opensource!
#2

Tested it with Linux Mint 18.2. It works, i can add images now. Great work AppyBuilder team. :+1::+1::+1::+1:

It gets harder and harder to choose between AI and it’s clones. I am using all versions now with more or less time spend on each. I like AI2 as the mother of them all. The commitment with which the developers are working all these years. I use Thunkable for it’s great Googlemap component. I discovered Makeroid and like the all new colors, the new ideas and the enthousiasm off it’s developers.
I like AppyBuilder also for it many years of existense and now it is made open source i think it will collect a lot of new users. For me AppyBuilder Offline makes all the difference. This is something unique and it’s working on all operating systems.


#3

@Peter_Mathijssen Glad you like it.

You mentioned Google Map. AppyBuilder has that component. Is that what you are referring to?

I should mention that Google map in offline version won’t work because it requires API key. We will update this component Do that you could pass the API key.

Let us know what other features you like and we’ll add it to list and eventually get to it :slight_smile:


#4

I guess you use the same googlemap component as makeroid. The punya version. The thunkable version is different and you can easily insert a custom track. I tested something in makeroid but i can’t get it working. The new map component from ai uses openstreetmap. But i would really like a googlemap version. If makeroid or appybuilder could make a googlemap component like thunkable i wouldn’t have to use thunkable anymore.


#5

I agree to this. Currently I use AppyBuilder for all other apps and Thunkable for maps apps because of custom marker feature.

Will be great to have it on AppyBuilder as well.


#6

Offline appybuilder usb companion not working


#7

@nandu_aeer we’ll check into it


#8

Thank. I’ve tried using it on my local server (windows 10). Everything seems fine until I try to build the apk. It fails to build it. Is there anything I need to do before building the apk?


#9

@habboubih What happens whey you try to build?


#10

Didn’t test if the apk could be build. I get the following error:


#11

@Peter_Mathijssen Do you have jdk installed or just jre?
You need to have jdk and in the java\bin folder, you need jarsigner.exe file


#12

I installed jdk and i get, don’t know if this is something that i am doing wrong or that it is AppyBuilder

SDK_BIN is: /home/peterm/AppInventor/AppyBuilderPersonal-master/AppEngine

Executing [/usr/lib/jvm/java-9-oracle/bin/java, -javaagent:/home/peterm/AppInventor/AppyBuilderPersonal-master/AppEngine/lib/agent/appengine-agent.jar, -Xbootclasspath/p:/home/peterm/AppInventor/AppyBuilderPersonal-master/AppEngine/lib/override/appengine-dev-jdk-overrides.jar, -classpath, /home/peterm/AppInventor/AppyBuilderPersonal-master/AppEngine/lib/appengine-tools-api.jar, com.google.appengine.tools.development.DevAppServerMain, --property=kickstart.user.dir=/home/peterm/AppInventor/AppyBuilderPersonal-master, --port=8888, --address=0.0.0.0, /home/peterm/AppInventor/AppyBuilderPersonal-master/GUIServer]
-Xbootclasspath/p is no longer a supported option.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
nov. 03, 2017 5:09:11 A.M. com.google.appengine.tools.admin.OutputPump run
SEVERE: Unexpected failure while trying to record errors.
java.io.IOException: Stream closed
at java.base/java.io.BufferedInputStream.getBufIfOpen(BufferedInputStream.java:170)
at java.base/java.io.BufferedInputStream.read(BufferedInputStream.java:336)
at java.base/sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
at java.base/sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
at java.base/sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
at java.base/java.io.InputStreamReader.read(InputStreamReader.java:185)
at java.base/java.io.BufferedReader.fill(BufferedReader.java:161)
at java.base/java.io.BufferedReader.readLine(BufferedReader.java:326)
at java.base/java.io.BufferedReader.readLine(BufferedReader.java:392)
at com.google.appengine.tools.admin.OutputPump.run(OutputPump.java:36)
at java.base/java.lang.Thread.run(Thread.java:844)


#13

I guess i didn’t install jdk after i upgraded my laptop. But my before that time always working ailivecomplete gives the same error.


#14

Actualmente el grupo de MitExtensions compiló la version offline instalable para Windows, requiere solo el instalador. Puedes verlo en el enlace.


#15

@Peter_Mathijssen. Sorry but I’m not clear on final result. After installing jdk; are you able to build apk?


#16

No still not working. Server terminates as you can see with errormessage.


#17

What java version do you have?


#18

java version "9.0.1"
Java™ SE Runtime Environment (build 9.0.1+11)
Java HotSpot™ 64-Bit Server VM (build 9.0.1+11, mixed mode)


#19

@Peter_Mathijssen That might be the issue. The offline was built based on java 8. These are good findings. We’ll update README based on findings


#20

Let me start by saying:

Thank you, thank you, thank you, thank you, thank you, thank you, thank you, thank you, thank you. :grin::grin:

It is working. :+1: