AppyBuilder Gold Companion not working?


#1

For the past two days I have been unable to test anything with the AppyBuilder Gold companion. I even uninstalled it and installed it again from the Play Store and downloaded version 3.18 from the link you posted elsewhere in this forum.

When I enter the 6-digit code the bar code on my laptop disappears, so it has connected with your server. But on the phone it just sits on the login screen, with nothing happening?

UPDATE: It started working again, although very slow.


#2

make sure you KILL all other companion apps


#3

I experience the same problem, since 2 hours ago. I have reinstalled Companion App but still not working.


#4

It is suddenly working again. I don’t know why. Thanks.


#5

@Ronin Is your device on same wifi as your computer?
Did you kill all other companion apps?


#6

Hossein, yes, same access point. No, i only use Appybuilder companion.


#7

Seems like i encounter this bugs pretty often. I used wifi connection. I guess i’ll try an emulator.

EDIT : I have tried App Inventor Emulator but failed. Any ideas how to use emulator with Appybuilder?


#8

You can’t use an Emulator with AppyBuilder. Sadly, MIT does not open source emulator source code.


#9

@Ronin does your app contain extensions that may contribute to issue? Switch to a simple project. Is companion able to connect?


#10

Yes, yesterday i have tried simple project @Nickon… i wonder if the server was too busy, half a day after that, i tried again and it is working again…


#11

The server is scalable and number of instances are increased based on traffic.