AppyBuilder error message while building: AAPT execution failed


#1

hep guys, please anybody help me,

I created an app with AppyBuilder, But when i Buid .apk file of my app than this dialog box will appear as shown below:


AppyBuilder is unable to compile this project.
The compiler error output was
________Creating fragment xml
________Generating manifest file
________Attaching native libraries
________Attaching component assets
________Compiling source files
(compiling com/appybuilder/technicalhero143/MoneyKey/Screen1.yail to com.appybuilder.technicalhero143.MoneyKey.Screen1)
(compiling com/appybuilder/technicalhero143/MoneyKey/HELP.yail to com.appybuilder.technicalhero143.MoneyKey.HELP)
(compiling com/appybuilder/technicalhero143/MoneyKey/redeem.yail to com.appybuilder.technicalhero143.MoneyKey.redeem)
(compiling com/appybuilder/technicalhero143/MoneyKey/Screen2.yail to com.appybuilder.technicalhero143.MoneyKey.Screen2)
(compiling com/appybuilder/technicalhero143/MoneyKey/Home.yail to com.appybuilder.technicalhero143.MoneyKey.Home)
(compiling /tmp/runtime7839059881555993456.scm to com.google.youngandroid.runtime)
Kawa compile time: 4.547 seconds
________Invoking DX
DX time: 28.781 seconds
________Invoking AAPT
YAIL compiler - AAPT execution failed.


.

Please friends help me, and one more thing, i use someone’s .aia file to build this app. please guys help me if anyone know what’s problem here


I have the below error at 30% of building my project
#2

First of all, where this .aia was created? In App Inventor? In Thunkable? In Makeroid?


#3

You should also check and see what extensions are used


#4

The .aia file is created in Appy builder


#5

What extensions does it use?


#6

Don’t Know…


#7

see if one of these threads can help
https://groups.google.com/forum/#!searchin/mitappinventortest/AAPT$20execution$20failed|sort:date
Taifun


#8

Extensions used are listed under the Palatte on the right hand side at the bottom, click “Extension” and you’ll see a list. My understanding is the they can often cause build issues (ran into this myself) that don’t manifest when you’re doing “Live Testing” with the Companion app.


#9

So, what’s the solution is? How to Build App?


#10

You are not providing much information. How are you creating the app if you don’t know what (if any) extensions are used? Also, what’s the exact case-sensitive name of the app?


#11

Remove extensions until the app builds, then find alternate ways to achieve the same task. It doesn’t sound like you wrote this yourself. Maybe hire someone who knows how to solve these problems?


#12

@Technical_Hero I just checked the logs. It seems like you changed the application package name and included a hyphen (-) in there. Package names can not have special characters or hyphens


#13

Any solution?..


#14

Thanks Buddy, for your help :slight_smile:


#15

Ohh, Thank YOu!!! It’s Working!!! I Solved This Problem With Clear My Packages Name! From Screen1


#16

clearing package name worked for me. I think it was because of changing package name repeatedly