After last update companion can't load a project


I was working on a project and since few days ago it was working fine, now when I do live testing the companion try loading the screen, failing it in loop. I did a short video recording to show what I mean: (724.5 KB)

App Auto Blinking Problem

Does it load for a small or empty project?

Clear companion/browser cache and restart then try connecting again.


@Gabryk Can you PM me your .aia? Does this happen for apps without extensions?


3 posts were merged into an existing topic: Companion(Ver.4.03) doesn’t work on my device


When I open the app and fill the text box, it’s time to start the app blinking. I do not know how !! But I need help solving this problem


Send. I think the problem is given by snack bar extension. But even if I tried to remove it the problem persists


I have a very similar problem. I’ve tried restarting all devices involved, clearing the browser cache, and disabling any screen.initialize blocks as well. Weird thing is, other projects and even new screens added within the project work fine. I don’t have any extensions added:

Other times, after a QR scan, it’ll just get hung up on the main screen of the companion with the code entered but won’t load the app, even though the QR disappears on the computer…

It last worked for me on Thursday, Apr 6, and hasn’t worked since trying Saturday morning.


Another weird thing is sometimes when I first load my blocks screen, the initialized variables have comments on them as a result of a "Do It: " with a bunch of jibberish after.


@glimmbo Next time this happens, can you export your .aia and PM it to me? This way, we can look into actual source to investigate the issue.



So a bit of an update with this problem: I tried creating a checkpoint. It seemed like maybe I had found a work around to make the Live Testing work again (without blinking an incomplete render of my design) by loading the checkpoint from the projects page, then switching to the initial project name (the state after the changes from the checkpoint). The app seemed to be working as normal but then started throwing new errors:


Adding to the weirdness of this problem…

I was able to get USB Live testing to work on a Windows laptop my friend loaned me. While working on my blocks however, “Do it: package results” are popping up when I change some of the “do” sections of my blocks.