Ads not showing


Dear all,

recently, I saw that Ads have not been shoewing in some of my Apps made with Appybuilder gold. Is anyone else also experiencing this? Please help me out!

Thank you for your kind attention


@Manas_Goyal make sure you didn’t violate AdMob policy


Nothing wrong with the policies. The ads show on older versions of the App; just not the new version…


Couldit be out of ad inventory? Did you check the AdFailedToLoad or Show blocks?


Yep. Nothing wrong with that either :frowning:


I know you have, but wasn’t to make sure that screen is set to responsive.

Also more info:


I’ve also done that… but thanks for the feedback! Is there anything else I can do to fix this?


@Manas_Goyal do you have a link to your apk? We can check and see if it displays for us


Sure. Here it is:


Thanks for your help btw! I appreciate it!


Hey! :slight_smile:

Just to follow up, can you see the ads? Are they visible to you?


I don’t see any banner ad


what type ads? banner or?
if banner you must check it s in arrangements or not.
my banner was not working in arrangements .so i take it out and could see it.


Hey! thanks for the reply!
yeah, its banner and interstitial ads too. i have tried to remove it from the arrangement but it wasn’t showing any ads. is there some other way? please help me out on this!


Did you Write your ads Id correctly? you can give a screenshot your blocks,or aia file.or apk so we can check it.maybe its working other devices.


I’ll check that! Hold up! :slight_smile:
Thanks for your help!! :slight_smile:


Mine is not working ether. tried with test adds and with my own.
It is set to responsive,the id is correct and its been well over 48 hours but the test adds should still show up wright ?
its funny cause it did show twice and both times it was when the app had a error on companion and crashed. any help would be grate.


If I’m not mistaken now admob has new policy that your app need to be installed via 100 different IP address, and you may need to wait for 14 days…


@Ronin, Where do you get this info from?


got it working i had change my setting from portrait to unspecified and then it worked.
after i changed it back to portrait it still worked i also deleted the component and put it back in but its working now. But now i have a new problem just came home from work and all my projects are giving me the same error The variable $number is not bound in the current context
I tried refreshing browser and phone and nothing is working. all my projects that worked fine before are all giving me this error. very frustrating. any one else having this problem?