Admob Working in test mode but not in live one


#1

Hi,
Admob is showing well while in test mode both for banner and interstitial.
However it is not working in live mode. In admob dashboard i see no ad requests

I am using Gold Appybuilder

In live mode: The error message showing is “Something happened internally; for instance, an invalid response was received from the ad server.” .

Thanks for your help (Screen sizing is already in responsive)

PS: I already use admob with other Gold appybuilder apps and it works well.


#2

@Baby_Smile is this new admon ad unit of?


#3

It is created since one month. I ve even tried with a working ad unit of another app but it shows the same message


#4

@Baby_Smile Check and see if it works with this id: ca-app-pub-7889867620272870/4062724292


#5

@Hossein I tried with this ID, It shows the same message


#6

Check attached .aia to show AdMob usage. admobTest4.aia (27.8 KB)


#7

Thanks @Hossein, But I already have 2 other apps with appybuilder where admob works fine. The problem I have is only with this app.
Even in Admob dashboard it shows no Ad request for this app
the package name of the app is appinventor.ai_Newbebiko.Simulation


#8

I think IF it is working with my ad-id and is working fine with your other apps, this means that there is something going on with your AdMob AdUnitId. Also, googling shows below:

> I was doing so, until magically, ads appeared in the game!
_> _
> It’s been 3 days I have this problem, and now it works, even though I modified nothing.
> Well, I can’t complain now, but I would have preferred this magical solution 3 days ago!


#9

It is not working with your ad-unit id


#10

What device do you have? See screenshot


#11

What I said is that your AD-unit is not working in my App. I believe the issue is not in the ad units but in the app itself.


#12

@Hossein I even tried to insert my AD UNIT into your app and it worked. But in my app it is not working. I checked it all but i can not find the origin of the problem


#13

When I put Package name to " " it works well !!


#14

What package name did you have?


#15

appinventor.ai_Newbebiko.Simulation
It is the package name I have since ai2


#16

i have older ad unit which is working in my one app but nit working in another error message says internally error invalid response found by ad server


#18

do you use any firebase component in your project ? … if yes … disable (PERSIST) option.


#19

Sir, now days so many user got this type of problem. I think appybuilder authority focus on admob new policy. Coz they change some thing on there policy


#20

Now a days admob are checking traffic level to providing ads on your ad unit and also checking frequency level of you loading ad unit in your apps to stop losses of advertiser and ban earning apps in india.

And next one after compiling your apk or update in play-store you have to wait some time to get ads.


#22

u can test ur unit here


and more details